Warcraft III TFT 1.22 Patch will not install

Discussion in 'Mac and PC Games' started by splendiferous, Aug 2, 2008.

  1. splendiferous macrumors newbie

    Joined:
    Jul 27, 2008
    #1
    I downloaded the patcher directly from the blizzard website and ran it. Everything runs smoothly until TFT needs to start up.

    I get the message "Frozen Throne: Warcraft III could not start up", and when I start up TFT, the patch has apparently not been installed.

    Any ideas on how to get around this?
     
  2. Mac Player macrumors regular

    Joined:
    Jan 19, 2006
  3. splendiferous thread starter macrumors newbie

    Joined:
    Jul 27, 2008
    #3
    I installed both ROC and TFT by mounting disk images (isos), which means that I'm using a crack CD code.
     
  4. Mac Player macrumors regular

    Joined:
    Jan 19, 2006
  5. splendiferous thread starter macrumors newbie

    Joined:
    Jul 27, 2008
    #5
    Tried that, but the patch wasn't installing, so now I'm trying to reinstall ROC and TFT and patching them before I run them.
     
  6. splendiferous thread starter macrumors newbie

    Joined:
    Jul 27, 2008
    #6
    So I reinstalled ROC and TFT, and tried patching both of them.

    The patch for ROC works, but I'm still encountering the same problem with TFT. I'm lost.
     
  7. Ornryactor macrumors newbie

    Joined:
    Jul 20, 2008
    #7
    You need to install ROC, then install TFT *without* patching ROC. Once TFT is installed, then start it up and try and connect to BattleNet. That will trigger the Blizzard Updater into patching your game. (The updater can't be started from outside the game.)

    The most recent patch *is* a no-CD patch; you don't need to use any third-party hacks to attain that. If you have the physical CDs available, definitely use those to install, and not ISOs.
     
  8. macsmister macrumors newbie

    macsmister

    Joined:
    Jul 19, 2002
    Location:
    Knoxville, TN
    #8
    Here is what you need to do:

    - Firstly you need to install the full 1.21 TFT patch.
    - Next you need to install the full 1.22 TFT patch.

    The TFT expansion will work after that. The reason for having to do that is because the 1.22 patch has a known issue when being applied with a fresh install of the game. I hope this helps!
     

Share This Page