Warhammer online - Minimum Specs Announced

Discussion in 'Mac and PC Games' started by macroduo, Jul 30, 2008.

  1. macroduo macrumors newbie

    Joined:
    Apr 10, 2008
  2. MacHipster macrumors 6502

    Joined:
    Sep 11, 2007
    Location:
    Chicago/London/Sydney
    #2
  3. recoman3 macrumors member

    Joined:
    Jul 26, 2007
    Location:
    Sydney
    #3
    pity its not coming to mac, and I deleted vista 2 months ago..
     
  4. macroduo thread starter macrumors newbie

    Joined:
    Apr 10, 2008
    #4
    hard to find low end grahpic card support Pixel Shader 2.0
     
  5. kahine macrumors regular

    Joined:
    Jul 10, 2008
    #5
    That's the point - nothing wrong with companies in 2008 expecting you to have 128mb ram video card for gaming that supports 2.0 - I'd say that's quite reasonable of an expectation

    Hoping they really have improved this game in past month - quit the closed beta couple months ago - going to try the open beta and head start -

    AoC just got too buggy with Funcom's patches breaking more than they fix -

    This is the one game I am keeping Vista64 on in bootcamp for -
     
  6. Ramminar macrumors newbie

    Joined:
    Aug 15, 2008
    #6
    Think I could use your beta account? I've been on applied status for over a year and still haven't gotten in.

    You have no idea how much it'd mean to me if yah did : )

    If you'd be willing to let me, could you PM the login info, or send it to me via email? CDank@hotmail.com

    <3

    Edit: Thanks either way!
     
  7. kahine macrumors regular

    Joined:
    Jul 10, 2008
    #7
    Went back to playing it finally - its definitely leaps and bounds better than it was , they may actually have a hit on their hands
     
  8. Ramminar macrumors newbie

    Joined:
    Aug 15, 2008
    #8
    Ah damn, that's cool. Good to hear it's making great progress.

    ... Think I can check it out? Lol. /beg

    I tried.
     
  9. Rodimus Prime macrumors G4

    Rodimus Prime

    Joined:
    Oct 9, 2006
    #9
    what are you talking about. My ATI 9600 I originally installed in my computer 4 years ago supported Pixel shader 2.0. Since then I have dropped a x800 into my PC tower but still meets those requirements.

    What are you stressing about that something mid grade cards from 4 years ago could meet.
     
  10. Kenza macrumors newbie

    Joined:
    Apr 19, 2007
    #10
    Since I am not overly familiar with that dedicated Intel graphics chip in my Macbook...would it be able to run Warhammer Online? And of course we are not talking top notch graphics settings here.^^ Or would it not even start, or maybe just fry my mac or whatever?

    Cheers,
    Kenza
     

Share This Page