Warning - Chameleon SSD Optimizer damaged my Yosemite upgrade

Discussion in 'Mac Basics and Help' started by XPcentric, Mar 14, 2015.

  1. XPcentric macrumors 6502

    Joined:
    Oct 16, 2008
    #1
    I'm posting in the programming area because there are some technical issues here like "mounting, boot volume" etc and want to find out, what was the cause of the problem, after I managed to get over it, you can learn form my experience as well as give an advice to the misterious problem:

    It happened this way:
    I upgraded from Mavericks to Yosemite my recent SSD. After upgrade there were two incompatible apps, Kindle and a Mobile-broadband-stick.app which where placed in a special folder. The first thing I've done was to open Chameleon SSD optimiser to check if the settings stayed the same. There are a couple of settings in this app:
    - enable noatime, -disable disk hibernation, and - enable trim. The first two were certainly on, and while I don't remember exactly the purpose of Trim and if my Samsung Evo 120GB SSD qualifies for it, I enabled Trim as well after upgrade and it prompted for a restart. That was the moment when the hell on earth started.

    I tried to boot but it stopped with the prohibition circle. I tried to reset NVRAM/PRAM but useless. Luckily I had an external WD with Yosemite installed, and my old internal hard drive to make tests. I used my old internal hdd to check that the cable hardware inside is still working and is not damaged and it booted whatever system I've put on it. I used my external WD to boot but found out that my external booted Yosemite could not mount my internal SSD: I tried with terminal with 'diskutil list', Disk utility and Startup disk form System preferences but was not visible. At this stage I was not even able to do a reinstall on the internal SSD;
    -not to mention the wasted hours trying to boot while holding the Alt keys and other tricks.

    But what is strange is that my SSD when booted externally via a USB-Sata adapter was working. That is the reason why I was worried previously about my internal sata cable being damaged. So I used my old hdd to install yosemite on it as well, and in total I've installed the upgrade three times and right now is midnight when I write this period.

    The misterious questions are:
    1) Does this app "Chameleon SSD optimizer" include any kind of malware I don't know about ?
    2) Why was my SSD not mounted ?
    (or which file did it get corrupted to cause my volume not to be mounted or to give the forbidden gray screen ?)

    In conclusion, next time I'll read more, do some tests, and optimize the SSD by hand. Good night!
     
  2. hokan macrumors member

    Joined:
    Mar 18, 2014
    Location:
    Sweden
    #2
    I've read about similar issues (failure to boot) among users that enabled TRIM for "non-Apple" drives. Enabling TRIM has historically been achieved by modifying certain OSX KEXT files. Yosemite (10.10) introduced signed KEXT files as a security measure, this resulted in TRIM suddenly breaking when upgrading to 10.10 - as it presumably removed the "hacked" KEXT files.

    This security feature needs to be disabled to be able to modify KEXT files i.e. to enabled TRIM for non-Apple supported drives.

    Note that any OS point releases could re-enabled signing checks.

    So Chameleon SSD Optimizer is probably not at fault.
     
  3. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #3
    It is not indeed and there is a very detailed explanation of the KEXT-signing changes in Yosemite (as well as the steps required to reenable booting on hosed systems) that you mentioned at Trim Enabler's FAQ.
     

Share This Page