iPhone Warning: don't change the FPS in CameraTweak 4's Video FPS setter! + quick review

Discussion in 'Jailbreaks and iOS Hacks' started by Menneisyys2, Aug 21, 2016.

  1. Menneisyys2, Aug 21, 2016
    Last edited: Aug 22, 2016

    Menneisyys2 macrumors 603

    Joined:
    Jun 7, 2011
    #1
    I have major problems on the current (0.9.3) version (official (read: non-pirated) one; as a customer of all previous CameraTweak versions, I could upgrade to this version for free.) Test device: iPhone 6s+ on 9.0.1.

    It seems it just can't save the modded value after the second modification. I set it to 240 (max) in 720p mode; after that, all other modes started to use their maximal frame rate (e.g., 1080p at 120p).

    I could only set it back to 30 fps by the traditional way (Settings > Photos & Camera > Record Video). The setting here, however, doesn't stick - when you change the resolution in CameraTweak 4 again, the old setting will creep back and you again need to pay a visit to Settings > Photos & Camera > Record Video to reset the new resolution's FPS etc.

    This is a MAJOR issue as all resolutions are affected, even if you only change the FPS in one of them.

    That is, for the time being, do NOT change the video FPS from inside CameraTweak 4!

    If the dev doesn't fix this issue, I'll look into it myself. I'm pretty confident I can fix it (by hacking the file system). Nevertheless, I do hope Samball fixes this bug.

    Otherwise, I can only recommend the tweak. Thanks to the new, vastly improved control features of the Camera API in iOS9, the tweak allows for accessing almost(?) everything possible via the new API (manual focus, manual/fixed ISO, manual shutter speed etc.).

    This means you can use the stock Camera-specific, absolutely essential features (HDR, the 6s/6s+'s exclusive Live Mode) not available (stupid Apple!) to third-party apps TOGETHER with the manual settings. The latter have only been available in third-party apps so far but not in the (except for exposure compensation) auto-only Camera app. Nevertheless, as 3rd party apps don't have access to the HDR / Live Mode, you could just not have the best of both worlds. Now you can.

    This tweak is a MAJOR reason for jailbreaking! Congrats, Samball!

    EDIT: I've mailed the developer. Hope he reacts quickly.

    EDIT 2 (23/08 07:14EET): please see #6 for a (temporary, but working) solution to the currently known bugs!
     
  2. iRetired macrumors 6502a

    iRetired

    Joined:
    Apr 21, 2012
    Location:
    WNY
    #2
    Bookmarked. Thank you. I've also already upgraded to version 4 but have not tried the video recording mode. However, I have a 6+ on 9.3.3 and will report back with my findings.
     
  3. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #3
    Thanks! It'd be great! I'm in constant communication with the dev; he surely welcomes additional input from owners of other devices / iOS versions.
     
  4. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #4
    I've continued playing with the problem. The problem is as follows: if you

    1. have a device that is capable of higher FPS in lower resolutions than on upper ones (and this is the case with most of them, starting with the 720p60-capable iPhone5 (only capable of 1080p30, of course)) and

    2. at a lower (more FPS-capable) resolution, set an FPS higher than the maximum FPS of the higher resolution (for example, even as low as 31 FPS for 720p / 1080p on the 6s+ - in 4k, the 6s+ is only capable of 30 FPS) and

    3. switch to the higher resolution that has a maximal FPS lower than the current one (then, the fps will be reset to the local maximum; for example, in the above example, from 31 to 30) and, finally,

    4. switch back to a lower resolution capable of more FPS than the current maximum,

    the FPS will be maximized. For example, on the 6s+, in 720p, 240 fps; and in 1080p, 120 fps.

    That is, if one wants to quickly switch between resolutions (like me – constantly switching between 720p and 4k to save storage for videos not that important (e.g., some family videos), while using 4k for stuff I deem important (I want to publish)), to avoid having to dial down the fps all the time at resolutions with higher maximum than the also-used one.

    BTW, on the 6s+ (9.0.1), one must just a little bit touch the label for it to be hidden (and the FPS overridden). On the iPhone 5 (9.0.2), much forceful touch is also accepted – there, you don't need to pay special attention NOT to touch the screen too hard. I've tried disabling the “3D Touch” feature of the 6s+ (also available on the 6s), but it didn't help. That is, you must very-very lightly touch the screen for the FPS setter to be hidden! Otherwise, it'll stay on.

    These problems have nothing to do with the following JB setup:

    - up-to-date Cydia core stuff
    - AFC2
    - AudioRecorder 2

    (these tweaks present on both devices).

    My 6s+, in addition, had the following:
    - CaptureView
    - f.lux
    - LocationFaker9
    - Display Recorder
    - Activator
    - Action Menu
    - iControlPhoto
    - NoSlowAnimations
    - 3G Unrestrictor (also unrestricting Camera to upload images over LTE too)
    - iFile

    None of these caused the problem - I’ve uninstalled them all, in the above order, but it didn’t help. (All tweaks are officially purchased and installed from Cydia Store. iFile is the registered version; that is, I have a license for the non-free version.)

    My 6s+ was also different in one aspect - for my panorama quality enhancer tool (see http://forums.macrumors.com/threads...e-iphone6-noise-filter.1928340/#post-22328064 ; v04 is the most up-to-date version), I’ve granted write rights for /System/Library/Frameworks/MediaToolbox.framework/N66/CameraSetup.plist so that my tool can directly tune some of the strictly pano-related values in there. It didn't cause the problem either – after restoring the original file (with the original read-only “World” rights), the bug was still present.

    NOTE: while the iPhone5 is capable of 60 fps at 720p, it was only originally (during the first run immediately after installing the tweak) that 60 fps was shown. Later, only 30 fps could be set for 720p. That is, on the iPhone5, the first bug can't be tested as 31+ fps (larger than the maximal FPS at 1080p) can't be set for 720p.
     
  5. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #5
    Yikes. Glad I read this before messing with camera settings of the tweak. :eek:
    --- Post Merged, Aug 22, 2016 ---
    I had no idea an app like CaptureView existed. It also doesn't mentioned being update lately, it's safe?
     
  6. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #6
    Good news: the dev was also able to reproduce the “maximized FPS upon switching back to a resolution capable of a higher FPS” bug on his iPhone 6+ and he'll fix the problem. He'll also fix bug 3 listed below.

    That is, with the current version, pay special attention to the following:

    1, the “maximizing” bug

    If you don't want to end up having to re-set the FPS every time you switch video resolutions (I certainly don't want as one of the reasons for my loving CameraTweak is the ability to as quickly as possible(!) switch between 720p and 4k, see above),

    do not set a higher FPS at the lower (more FPS-capable) resolution you plan to use than the maximum FPS your favourite resolutions are capable of!

    That is, assuming you have a 6s / 6s+, if you plan to use as large framerate as possible and plan to quickly switch between

    - 720p and 1080p, the highest FPS you'll want to set at 720p is 120 as 1080p is not capable of more
    - 720p / 1080p and 4k, the highest FPS you'll want to set at 720p / 1080p is 30 as 4k is not capable of more

    2, the 6s / 6s+ “not registered tap” bug

    As you know, you must tap the center label of the FPS setter to make the set value the selected one. This only works on the 6s / 6s+ if you VERY lightly touch the screen. By “standard” touches, the selector will most likely remain on the screen (and the new FPS value not set). Modifying the “3D Touch” settings in the standard system-level Settings won't help.

    3, the Landscape vs. Portrait resolution slider bug

    (I haven't mentioned this bug before. It is a bug of the resolution slider and not in the FPS setter)

    Another pretty annoying bug in the current version is as follows: with the resolution slider only the portrait resolutions are properly used. When switching to landscape, the values become completely messed up. For example, if you’re in 720p in Portrait and, then, switch to Landscape, 720p becomes 1280p. However, now, when you do open the resolution slider, the activated one will be 288p and not 720p any more. It seems you'll want to always switch back to Portrait before changing the video resolution via the slider.
     

Share This Page