Warning message: More than one Windows Partitions...

Discussion in 'Windows, Linux & Others on the Mac' started by iaddict, Mar 3, 2008.

  1. iaddict macrumors 6502

    Joined:
    May 15, 2007
    #1
    I got this message today when trying to start up Parallels: More than one Windows partitions are found. This is not a standard Boot Camp configuration. Please refer to the parallels Desktop for Mac User Guide, Using Boot Camp Windows XP Installation chapter for instructions on how to configure Parallels virtual machine in case of a non-standard Boot Camp configuration on your Macintosh computer.

    So, Saturday I shut down Windows from inside the Windows window then shut down Parallels. I have done it this way numerous times (was instructed to do it this way) and no problems. I do not know much about this or even understand how Parallels works, just have used it on my iMac for about 7 months or so now. If anyone can give me some step by step instructions on how to get Parallels back up and running, I would greatly appreciate it. The information on version etc I've listed below:

    Parallels version: build 3214
    Windows XP sp2
    Mac OS 10.4.11
     
  2. Siron macrumors 6502

    Siron

    Joined:
    Feb 4, 2008
    Location:
    North Carolina
    #2
    Do you have Time Machine running. If you do then Parallels detects the partition on Boot Camp and the copy in Time Machine back up. I had the same problem with my external back up drive.
    If I disconnect it Parallels works fine.

    Here is what Parallels told me to do:
    Hello,

    To solve the problem please follow these steps:
    1) Please open Applications->Utilities->Terminal run "diskutil list"
    command. From the output you may know which partition is occupied by
    Windows.
    2) Open .pvs file that is located in Mac HD -> Users -> Your login name
    -> Documents -> Parallels file with TextEdit.
    Look for a line containing something like "Disk 0:0 image = Boot
    Camp;disk0s3".
    The X value in 'disk0sX' is the number of Windows partition.
    3) Change the value for the one you had in output.

    Hope this helps.
    Alan
     
  3. GSi095 macrumors newbie

    Joined:
    Jun 30, 2008
    #3
    Hi,

    Thanks for this it worked

    I had "Disk 0:0 image = Boot Camp" and replaced it with "Disk 0:0 image = Boot Camp;disk0s3" and it worked.

    I spent so long looking for a fix, yours was simple

    Dave
     
  4. brytang macrumors newbie

    Joined:
    Aug 21, 2008
    #4
    Done! thanks!


    Thanks guys, I had the same problems, and it has been done!

    Previously my VMware always told me that my windows partition was not clearly shut down. After rebooted for 1000 times I had to turn to Parallels for any chance. Then I encountered the same trouble as you guys did.

    Now I can run windows under Leopard again, thanks!
     
  5. Storm Shadow macrumors regular

    Joined:
    Oct 27, 2008
    #5
    Thanks, this helped me too!
     
  6. Markf11 macrumors member

    Joined:
    Oct 31, 2007
    #6
    Good post, but what about if your not using Time Machine at all ?

    i have the message, i've probably not set up my partition with boot camp properly.
    I'm sure i did...but apparently not. My Parallels says i have two Windows options, XP (the one i know i did) and My Boot Camp, i dare not delete one or the other as i've just spent ages getting things back on there
    Can anyone lend a idea?
     
  7. superbuka macrumors newbie

    Joined:
    Dec 22, 2008
    #7
    Worked but had to type in the ";disk0s3" part

    It was working fine for months and then I got that same warning message. I opened the "My Boot Camp.pvs" file with text edit and had the type the last part in at the end of this line:
    Disk 0:0 image = Boot Camp;disk0s3

    I saved and then it opened right up again!

    Thanks for saving a lot of headaches!!!
     

Share This Page