"Warning: Remote Host Identification Has Changed" on SSH

Discussion in 'Jailbreaks and iOS Hacks' started by erandall38, Sep 13, 2007.

  1. erandall38 macrumors 6502

    Joined:
    Jun 24, 2007
    #1
    I have been able to connect to Fugu countless times to my iPhone.

    I just did a restore and downloaded installer.app with BSD and openSSH and now it give me the message in the subject line... anyone know what it means?

    And is there some program out there that is very reliable on connecting to SSH all the time. Cyberduck has never worked for me and Fugu just stopped witht his message. Am I doing something wrong?
     
  2. racemize macrumors member

    Joined:
    Jul 2, 2007
    #2
    it just means that your iPhone is reporting itself with a new key. If you go to ~/.ssh and delete the file "known hosts" it will go away. You know what the device is, so the warning doesn't apply in this case.
     
  3. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #3
    Go into your user folder and hit CMD + Shift + G and type ".ssh". Delete the known hosts file. Next time you ssh on your phone it will query you if its ok.
     
  4. erandall38 thread starter macrumors 6502

    Joined:
    Jun 24, 2007
    #4
    Thanks guys it worked and got me back in SSH!
     
  5. ntrigue macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #5
    THANK YOU! I knew what I had to do and could not locate "known_hosts"

    I was in Terminal rm "homefolder"/.ssh/known_hosts
     
  6. raseri macrumors newbie

    Joined:
    Feb 16, 2008
    #6
    No folder exists when I follow those instructions, I tried it in several places. Any other ideas? I keep getting the same error "Remote Host Changed." I have also deleted all the previous data from Fugu.

    enter

    rm -f ~/.ssh/known_hosts

    into 'terminal' on the Mac, return <---- worked first try
     
  7. Applows macrumors newbie

    Joined:
    Dec 11, 2008
    #7
    Thanks darngooddesign. I tried it, and it worked. For those who couldn't find the file, please try these steps:

    1/ Double click Macintosh HD on your Desktop

    2/ On the left side of the box, under Places, and click on your user name (mine is mac). This will take you to your home folder.

    3/ At your home folder, do a key combination <command> + <shift> + <g>. A "Go to the folder:" box will pop up. Type .ssh in the box then hit <return>. This will take you to the known_hosts file. From here, you can delete this file.

    I hope this help.
     
  8. ellsworth macrumors 6502a

    Joined:
    Jun 13, 2007
    #8
    Just a heads up. I had this problem today and what darngooddesign said worked. Thanks a lot. Saved me opening a new thread ;)
     
  9. JoseJ macrumors newbie

    Joined:
    Jul 17, 2008
    Location:
    Chorley, Lancs
  10. MST macrumors 6502

    MST

    Joined:
    Dec 3, 2007
    Location:
    Surrey, UK
    #10
    Sorry to drag up an old post but this has just helped me SSH back into my ATV2 after a little hiccup, cheers ;)
     
  11. Hot-Apples.com macrumors newbie

    Joined:
    Aug 28, 2011
    #11
    Yay

    I've been having a problem with this for so long.

    THANK YOU Applows for the solution! :) :) :)
     
  12. frysteen macrumors newbie

    Joined:
    Sep 11, 2011
    #12
    Thank you!

    just register here so that I can say thanks....THANKS! :)
     
  13. AllThingsI macrumors newbie

    Joined:
    Dec 16, 2011
  14. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #14
    I forgot these exact steps; I wasn't in my user folder when I tried CMD+SHIFT+G. So my advice just saved my own butt. Too funny.
     
  15. bobright macrumors 601

    Joined:
    Jun 29, 2010
    #15
    Can somebody explain to me how to do this? I have Forklift and I cant get into my iPhone 5 getting this error. Where is this "user folder"? Im new to Macs I was able to pull up the find folder command via finder but it doesnt find anything?
     
  16. Leetut macrumors newbie

    Joined:
    Jul 27, 2012
    #16
    thanks dude THIS WORKED

    i dont do terminal (thats why i bought an imac, Mr Jobs said "its just easy")!!!
     

Share This Page