Warning to Beamer users: Do not upgrade to 3.0.

Discussion in 'Apple TV and Home Theater' started by matrix07, Nov 21, 2015.

  1. matrix07 macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #1
    You're fine as it is. Do not upgrade.

    The latest version adds support for Chromecast but Apple TV users get no additional benefit. And even though you can still use 3.0 unlimited if you're 2.0 user, you still need to get rid of upgrade window that will appear every time you're launching the app, which is very annoying.
     
  2. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #2
    I upgraded to version 3.0 and I think it's a nice update. First of all current 2.xx users can pay what they want. I paid $10 because I think it's worth it and I want them to continue developing the app. It's also my most used media/streaming app.

    Why don't you let people decide for themselves rather than posting a silly comment like you did. Oh and by the way there are improvements and some new features for Apple TV users.
     
  3. benjitek macrumors 6502a

    benjitek

    Joined:
    Sep 23, 2012
  4. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #4
    Stream any format video from Mac to Apple TV. Beamer is great app. Works much better than iTunes.
     
  5. matrix07 thread starter macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #5


    Such as..
     
  6. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #6
  7. matrix07 thread starter macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #7
    Support for .sup, .sub and .idx is nice but this "Supports the fourth-generation Apple TV" is kinda misleading. Beamers 2.0 already works great with ATV4. With H.264 passthrough checked, my 2011 MBA can already play full Blu-Ray rip without stuttering. The experience is great. Now it's less so because there is one window get in the way every time you're launching the app. So be warned.
     
  8. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #8
    First of all I have no idea what you're talking about with the upgrade window. I never saw one.

    Secondly using the remote to skip to next video is a big improvement in my opinion. And third it's not misleading. It supports Apple TV 4th gen. That's a fact so I don't understand what's misleading about that.
    Lastly I'm not here to argue with you. I just don't think it's right to post some misleading information and then tell users not to update. Let people make up their own minds especially when they can update for as little as a dollar or two if that's what they choose.
     
  9. matrix07 thread starter macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #9


    That's because you had paid.
     
  10. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #10
    Oh I get it...you want Beamer 3.0 but you don't want to pay for it. How cheap can you get...wow :rolleyes:
     
  11. matrix07, Nov 21, 2015
    Last edited: Nov 21, 2015

    matrix07 thread starter macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #11
    I don't want Beamers 3.0. That's the point. Beamers 2.0 is already working great and 3.0 will be unnecessary for many people. This thread just to warn people who doesn't need the 3.0 to not upgrade since it'll annoy them.
    Thank God I have Time Machine and can get my 2.0 back.
     
  12. Geert76 macrumors 65816

    Joined:
    Feb 28, 2014
    Location:
    the Netherlands
    #12
    using Beamer 3.0 without any pop ups or what so ever. My most used streaming app as well. 3.0 was such a great update for me!
     
  13. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #13
    Again...you're speaking for other people. Stop!! Speak for yourself and only for yourself. I get it you don't want it. Then why in hell did you install it? The devs sent out emails and linked to the what's new section so you can make an educated decision. You chose to install it, decided you don't want to pay for it, and are now complaining about popup windows encouraging you to update. Don't you see how ludicrous that is?

    You also don't have to use time machine. When Beamer 3.0 installs it moves Beamer 2.xx into a folder inside Applications.
     
  14. matrix07 thread starter macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #14
    False.
    The last email I got from Beamers was from a year ago.

    Again, false.
     
  15. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #15
    I don't like to be called a liar. The email is how I found out about the update. And when I installed 3.0 it clearly said in a popup that Beamer 2.xx would be moved to a folder inside Applications. After installation finished I checked and yes it's there.

    As of this reply I'm done with you. It's simply not worth it and you obviously don't have the capacity to admit when you're wrong.
     
  16. Geert76 macrumors 65816

    Joined:
    Feb 28, 2014
    Location:
    the Netherlands
    #16
    you are totally wrong. I have received the email from Beamer as well as the Beamer 2 in the application folder. So in this case, again, its you who's completely wrong with accusing other people here of false statements
     
  17. nooaah macrumors 68000

    nooaah

    Joined:
    Sep 3, 2009
    Location:
    Philadelphia, PA
    #17
    OP, the hysterics are kind of unnecessary. Deal with it. It's not bothering the rest of us. I guess since we paid for it. Stop telling us how we should feel about the new version and what we should do with it.
     
  18. matrix07, Nov 22, 2015
    Last edited: Nov 22, 2015

    matrix07 thread starter macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #18
    What is the name of the folder? It's certainly not beginning with Beamers... or Backup...

    If it's named Beamer 2 then it's not there for me.
    And Plex just sent news to me as late as this September so my email is working.

    Like I said, you won't be affected if you paid but this need to be warned. A perfectly working app turning a bit annoying without any substantial benefit for AirPlay users.
     
  19. b0fh666 macrumors 6502a

    b0fh666

    Joined:
    Oct 12, 2012
    Location:
    south
    #19
    my man, I hope u never need to become a vmware or parallels user :D
     
  20. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #20
    Here's where mine is. If you don't have it then I suspect user error.
    I made an exception but don't expect anymore replies from me.
     

    Attached Files:

  21. matrix07, Nov 23, 2015
    Last edited: Nov 23, 2015

    matrix07 thread starter macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #21
    And here mine:
    [​IMG]

    What user error is there for installing app? Don't you just.. uh.. click install? :rolleyes:
     
  22. besler3035 macrumors 6502a

    Joined:
    Oct 29, 2004
    Location:
    Grand Rapids, MI
    #22
    You do know you can pay whatever the heck you want for the upgrade, right? Including $0.00? I just did that. Works fine. No more upgrade notifications.
     
  23. matrix07 thread starter macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #23
    I know that, but there's no way I pay $0.00. That's like cheating. It'll be either an acceptable amount or none at all.
    Good for them for accepting that though.
     
  24. besler3035 macrumors 6502a

    Joined:
    Oct 29, 2004
    Location:
    Grand Rapids, MI
    #24
    Then, again, why are you complaining? Your thread title makes it sound like the 3.0 version breaks something. I've re-read this thread three times and I'm still not getting what the problem is. If you don't want to upgrade...don't. If you want 3.0, go right ahead and either pay $0.00 or pay what you find appropriate. Plain and simple.
     
  25. matrix07, Nov 24, 2015
    Last edited: Nov 24, 2015

    matrix07 thread starter macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #25
    It's not a complaining. It's a warning to people who's already happy with 2.x. The 3.0 has little added benefit for AirPlay users but if you upgrade you'll face with upgrade window that will annoy you every time you launch the app. Some people just don't wanna pay $0.00 because it's like cheating. If they don't need .sup or .sub/.idx support they are likely to be more happy with the existing 2.1.3, like I do. What is hard to understand?
     

Share This Page