Warning when Charging IP4

Discussion in 'iPhone' started by Jnardis, Aug 3, 2010.

  1. Jnardis macrumors 6502a

    Joined:
    Jun 2, 2010
    #1
    I noticed that when I plug in my IP4 to charge I sometimes get a notice saying that this devise is not compatable with this charger. The device will not charge. It happens really quick then starts charging and then stops and the warning comes up. I'm using the charger that came with the phone. Has anyone else had this problem? Could this be ruining my battery?
     
  2. jacollins macrumors 6502a

    Joined:
    Jun 19, 2010
    #2
    Mine doesn't do this. What do you have the charger plugged into? Wall/laptop/desktop/usb hub what? I've heard of issues with charging from some USB ports and hubs for example (although I don't know if it says incompatible).

    If it is consistent, I'd take it in to an Apple store.
     
  3. NikeTalk macrumors 6502a

    Joined:
    Apr 5, 2010
    #3
    This has happened to me with my Bose sound dock which is completely compatiable.
     
  4. SAD*FACED*CLOWN macrumors 65816

    SAD*FACED*CLOWN

    Joined:
    Apr 5, 2010
    Location:
    Houston, TX
    #4
    I had a old iPhone charger from the original and when I would attempt to plug it into my 3G and 3GS it would throw that message I later discovered that it was doing that because it wasn't completely plugged in and the latches on the side had worn down so it wouldn't stay completely plugged in
     
  5. jacollins macrumors 6502a

    Joined:
    Jun 19, 2010
    #5
    Maybe a bumper thing then? ie. it doesn't plug in all the way with the bumper on and gives the message?
     
  6. Jnardis thread starter macrumors 6502a

    Joined:
    Jun 2, 2010
    #6
    I'm plugging it into the wall and I do not have a bumper. It hasn't happened to my gf's Iphone 4 yet.
     
  7. bowlerman625 macrumors 68020

    bowlerman625

    Joined:
    Jun 17, 2009
    Location:
    Chicago, IL area
    #7
    Mine too. But it does charge the iPhone 4.
     
  8. Bkasm macrumors member

    Joined:
    Jul 27, 2010
    #8
    I had this message appear when using the iP4 with the original iPhone (2G) dock.
     

Share This Page