Watch completely discharged after 7 hours

Discussion in 'Apple Watch' started by BaggieBoy, Jun 23, 2015.

  1. BaggieBoy macrumors 6502

    BaggieBoy

    Joined:
    May 29, 2012
    Location:
    UK
    #1
    I updated to 2.0 on Sunday. On Monday it was 100% at 6:30AM and was fine all day, at 11:30PM it was down to 32%. I then charged it overnight and again at Tuesday 6:30 it was 100%. Around 11:30AM I noticed it was down to 47% which seemed strange, I'd not used it heavily. At around 1:30PM I checked it and it is completely dead, I assume the battery is fully discharged. I don't have a charging cable with me...

    Can't understand why the difference in battery performance between the two days.
     
  2. phpmaven macrumors 68040

    phpmaven

    Joined:
    Jun 12, 2009
    Location:
    San Clemente, CA USA
    #2
    It's watchOS 2.0. It's a buggy mess. Of course it's beta and bugs are to be expected, but it's the buggiest beta that I've ever seen from Apple. I had a bunch of different problems and battery life was one of them. I finally sent my watch in and had it flashed back to 1.01. What a difference. I'll never make that mistake again.
     
  3. BaggieBoy thread starter macrumors 6502

    BaggieBoy

    Joined:
    May 29, 2012
    Location:
    UK
    #3
    I find it hard to believe that the battery life is so different from one day to another though just because of 2.0.
     
  4. Jordan921 macrumors 68040

    Jordan921

    Joined:
    Jul 7, 2010
    Location:
    Bay Area
    #4
    It's a beta. You will probably find more answers if you actually posted on the dev beta forums.
     
  5. ant69 macrumors regular

    ant69

    Joined:
    Feb 2, 2009
    #5
    this is why we have beta testers! people who accept these issues, and find new issues/problems/bugs - so apple get more data for the final release, thanks for your help :)
     
  6. Newtons Apple macrumors P6

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #6
    I find it hard to believe that you are not considering that the Beta 2.0 could be the problem.

    It worked fine before and after it did not.

    Think about that.:rolleyes:
     
  7. IllusionEntity macrumors 6502

    IllusionEntity

    Joined:
    Jun 23, 2013
    Location:
    Kent, UK
  8. BaggieBoy thread starter macrumors 6502

    BaggieBoy

    Joined:
    May 29, 2012
    Location:
    UK
    #8
    I upgraded on Sunday, battery life was fine on Monday and not on Tuesday. So the switch from 1.01 to 2.0 was not the trigger.

    I've run plenty of Apple Betas and the battery life is always impacted, but usually in a consistent way. I've never seen a beta that caused a 4 times greater drain from one day to another.

    Anyway I won't bother you anymore, I've raised a bug report.
     
  9. moetownslick macrumors regular

    moetownslick

    Joined:
    Jun 15, 2009
    #9
    it has to be the beta...i'm still on 1.0 and i'm going on hour 32 and I still have 36% battery left.
     
  10. Mac2me macrumors 6502a

    Joined:
    Jun 10, 2015
    #10
    Not a developer but read a number of threads in this forum section regarding those that did upgrade to the beta and wanted to downgrade because of battery depletion. So you're not alone in experiencing this. Check out the downgrade thread and the little things thread if you want to hear other's experiences.

    Frustrating for you guys I'm sure but glad you are out there working to make the release better before the rest of us get it.
     

Share This Page