Watch died? Anyone had this issue?

Discussion in 'Apple Watch' started by MagicHAM, Sep 22, 2016.

  1. MagicHAM macrumors regular

    MagicHAM

    Joined:
    Sep 2, 2013
    Location:
    Australia
    #1
    Just happened randomly. and I can't seem to turn it back on. have it on charge and nothing has come up. I don't know what has happened to it. it was last working like 30 minutes ago when I got a notification for some emails. But now it's completly off and i can't turn it back on (and obviously just tried the charging that doesn't work either.

    Battery was at like 78% when it died.

    Has this happened to anyone else?

    I'm going to book an appointment tomorrow at the apple Store because I seriously can't work out what has caused this. Everything was working fine with it.

    Just to reiterate battery was at 78% so there was no flat battery.

    Edit:
    Just did a force restart of the watch, loading up again... But seriously that was weird. I never had anything like that completly die unless it was being used by Meg Griffin.
     
  2. DerekZoolander macrumors newbie

    DerekZoolander

    Joined:
    Apr 9, 2015
    #2
    Yes this happened to me once on my series 0. No response what so ever from charging or trying to turn on. I was about to make an Apple store appointment too but tried a force restart first after I read a couple forums. Don't know why it didn't try that to begin with. Anyhow that brought it back to life. The issue never happened again. I guess it was an iOS glitch I suppose.


    Incase you haven't tried force restarting, press and hold both the side button and Digital Crown for at least 10 seconds, or until you see the Apple logo.
     
  3. jamdex macrumors member

    Joined:
    Jul 8, 2012
    Location:
    Manchester UK
    #3
    My AW2 SS randomly switched itself off yesterday, switched back on ok though. Thought it was strange...
     

Share This Page