Watch died on me today while updating to 2.0.1. Anyone else?

Discussion in 'Apple Watch' started by Advil, Oct 21, 2015.

  1. Advil macrumors 6502a

    Joined:
    Oct 4, 2008
    #1
    I was updating my watch and suddenly got the dreaded red exclamation mark. I ended up going to the apple store and waiting on a walk-in appointment for 3+ hours and they said they can't restore it or replace it, but have to send it in for repair.

    It's annoying that they can't restore the operating system in store but I guess I had no choice. Anyone else have any issues?
     

    Attached Files:

  2. TomH TX, Oct 21, 2015
    Last edited: Oct 21, 2015

    TomH TX macrumors regular

    Joined:
    Oct 18, 2010
    #2
    Thankfully, I have not had that problem, but understand your frustration. I am assuming that you tried and/or they tried the "force restart" with no success? Was it on the charger when it failed? ?? What does the watch app on the phone tell you? More info please.
     
  3. Advil thread starter macrumors 6502a

    Joined:
    Oct 4, 2008
    #3
    Yeah it was on the charger and was updating as normal when it suddenly went to that screen. I tried to force restart countless times and then got on support chat with Apple. They told me to take it into the store. The Watch app opened up as normal and didn't even realize that something was wrong. I unpaired it per Apples request.

    I think it's just a corrupt install of the OS which isn't even a big deal, it's just that they don't have a way to restore them as new in the store and it's really silly.
     
  4. TomH TX macrumors regular

    Joined:
    Oct 18, 2010
    #4
    I find this question interesting, and have been running searches since my earlier post. There are numerous articles and threads about the dreaded exclamation point, but NO actual solution other than having to send it in. I agree that it is ridiculous that there is NO way to get past the exclamation point. At least on phones or iPads you can sometimes try things like a DFU restore. I wish I had been able to find something useful for you. Good luck, and let us know what if anything they tell you.
     
  5. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #5
    http://www.imore.com/apple-watchos-2-update-failing-or-frozen-heres-fix
     
  6. TomH TX macrumors regular

    Joined:
    Oct 18, 2010
    #6
    Armen - that is an interesting article, and helpful in other contexts, but does not appear to have any actual solution of how to get past the exclamation point problem.
     
  7. Rok73 macrumors 65816

    Rok73

    Joined:
    Apr 21, 2015
    Location:
    Planet Earth
    #7
    Nice band color. This isn't original Apple, is it?
     
  8. Advil thread starter macrumors 6502a

    Joined:
    Oct 4, 2008
    #8
    Moko from Amazon.
     
  9. NumBerS912 macrumors member

    Joined:
    Sep 18, 2008
    Location:
    Cheltenham, UK
    #9
    Not broken, but I can't install. Keeps saying cannot verify as I'm not connected to Internet. 10 times tried now.
     
  10. Dalex299 macrumors newbie

    Joined:
    Nov 22, 2015
    #10
    This happened to me also. Before having the watch for 24 hours I got the red exclamation during update.

    Apple would only offer to send the watch off for repair. Returned it to Best Buy who replaced it as a defective device. Thank you Best Buy!






    Apple Watch Sport 42mm
     

Share This Page