Watch not automatically connecting to cellular

Discussion in 'Apple Watch' started by slefkoff, May 24, 2018.

  1. slefkoff macrumors newbie

    Jun 6, 2007
    I don't use the cellular option on my Series 3 (T-Mobile) Apple Watch very often, maybe once a month. Each time I move far enough from my phone to lose the connection to the phone, I get the red "X". The only time it will connect to cellular is if I restart it. Anyone have that problem? Solutions? TIA.
  2. bbednarz macrumors 6502a


    Nov 16, 2017
    How long are you waiting before restarting it? When I move out of Bluetooth range I will get the red X and then it figures out that it needs to connect to cellular. I've never timed it, but I would say it takes less than a minute. I also have T-Mobile.
  3. slefkoff thread starter macrumors newbie

    Jun 6, 2007
    I'll wait a long time. Last time I went for a 25 minute run. When it hadn't connected maybe 15 min in, I restarted it. Then it connected instantly. It seems to only happen when I stay connected to my phone (and don't use cellular) for a long time.
  4. Shirasaki macrumors 604


    May 16, 2015
    I don’t use US carrier but my Telstra network is connected very quickly when phone signal is lost.
  5. akidokraja macrumors newbie

    Jan 19, 2013
    Exact same thing I just went through. And the solution for me was to reset All Network Settings in iPhone. After that it connects fine.
    The issue is that the watch will try to connect to WiFi and if there are open WiFi networks in the area it will think it has internet connection while in reality it doesn’t. It’s a bug that has been there since AW3 cane out. Apple said they fixed it but it doesn’t seem like it. I am on 4.3.

    Hope that helps.
  6. RyCan3 macrumors 6502a


    Jun 13, 2010
    Seems like this just recently started for me as well. It’s pretty annoying.
  7. Trent0341 macrumors 6502

    Jun 3, 2007
    The last time I disconnected I had this issue as well. It seems intermittent more than anything.
    Provider: ATT
    watchOS: 4.3

Share This Page