Watch sending emails from @icloud.com rather than @me.com

Brookzy

macrumors 601
Original poster
May 30, 2010
4,747
4,723
UK
Has anyone else noticed that the watch doesn't copy the default from address settings from your iPhone?

E.g. if you have an iCloud email account that was set up back in the days of MobileMe (or even earlier) then you can continue to use your @mac.com and @me.com address.

There seems to be no option to change this.

While it is a minor problem, it means that if I email someone from the watch, it interrupts an email thread/grouping on the recipient's end, and if they subsequently respond to it, your conversation has effectively been split into two.
 

Pete the Geek

macrumors regular
Mar 5, 2011
186
0
Sioux Lookout
I just tested and indeed my email was send from my icloud account. This could be confusing. It could also cause me trouble if I send a work email; I'm supposed to use my work email. I couldn't find any option to change the default account or set the outgoing account on a new email.
 

chabig

macrumors 603
Sep 6, 2002
5,905
3,145
Has anyone else noticed that the watch doesn't copy the default from address settings from your iPhone?
My watch is set to mirror my phone, and iCloud is my default email account. Both Mac.com and me.com are iCloud addresses. My guess is that the return address is the one you used to log into iCloud. Which one are you logged into?
 

Brookzy

macrumors 601
Original poster
May 30, 2010
4,747
4,723
UK
My watch is set to mirror my phone, and iCloud is my default email account. Both Mac.com and me.com are iCloud addresses. My guess is that the return address is the one you used to log into iCloud. Which one are you logged into?
Neither. My Apple ID is a non-Apple address, with a @me.com and @icloud.com Mail address (like most people - it was only possible to set up an Apple ID without a third party address very recently).

I can't believe this isn't more widely reported. It basically means you can't reply to email on the watch.

(Shows you how few people use the watch for anything other than notifications and fitness...)
 

chabig

macrumors 603
Sep 6, 2002
5,905
3,145
Try this...it's definitely buried. On your iPhone, so to Settings > Accounts & Passwords. Then scroll down to the Advanced section and select Mail. Under iCloud account information, select Email. This is where you choose your default email address. Make sure your desired return email address is the one you want.
 
  • Like
Reactions: jusacruiser

Brookzy

macrumors 601
Original poster
May 30, 2010
4,747
4,723
UK
Try this...it's definitely buried. On your iPhone, so to Settings > Accounts & Passwords. Then scroll down to the Advanced section and select Mail. Under iCloud account information, select Email. This is where you choose your default email address. Make sure your desired return email address is the one you want.
Thanks for that - the @me.com is selected as the default though!

Apple needs to add a similar settings pane in the watch app.
 

chabig

macrumors 603
Sep 6, 2002
5,905
3,145
Since the phone has the correct default, maybe you can force the watch to take it by cycling the switch in the watch app that mirrors the iPhone. Set it to custom and then return it to mirror. If that doesn't work, try putting it in custom, restarting the watch, and then setting it to mirror the phone.
 

Pete the Geek

macrumors regular
Mar 5, 2011
186
0
Sioux Lookout
I fixed this issue by changing iPhone Settings->Mail->Default Account to my actual Hotmail account. It had been set to iCloud. I'd still like to have a way to select which account to use for new email on the Apple Watch, but honestly I won't be creating many new emails on my AW.
 

jusacruiser

macrumors 6502
Mar 15, 2009
325
8
Palm Beach, Florida
Has anyone else noticed that the watch doesn't copy the default from address settings from your iPhone?

E.g. if you have an iCloud email account that was set up back in the days of MobileMe (or even earlier) then you can continue to use your @mac.com and @me.com address.

There seems to be no option to change this.

While it is a minor problem, it means that if I email someone from the watch, it interrupts an email thread/grouping on the recipient's end, and if they subsequently respond to it, your conversation has effectively been split into two.
So put it simply.....which email address should me used? me.com or iCloud.com?
[doublepost=1543114709][/doublepost]
I just tested and indeed my email was send from my icloud account. This could be confusing. It could also cause me trouble if I send a work email; I'm supposed to use my work email. I couldn't find any option to change the default account or set the outgoing account on a new email.
So put it simply.....which email address should me used? me.com or iCloud.com?
 

Nell

macrumors 6502a
Jun 25, 2012
561
246
London
My watch generally only shows email from one gmail account; replies go from that account.

I’ve just tried adding my me.com/icloud.com account and it looks like that’s sending from me.com so all fine here.
 
  • Like
Reactions: jusacruiser

Brookzy

macrumors 601
Original poster
May 30, 2010
4,747
4,723
UK
This thread was started a while ago, I have just tried it again and the issue is fixed now.
 

Mind The Mac

macrumors newbie
Jun 7, 2009
20
0
This thread was started a while ago, I have just tried it again and the issue is fixed now.
I have only just read these posts and noticed my AW S2 is using an iCloud domain, not my default reply to email. Like other posters, I have tried all the suggestions etc. When changing from Mirror iPhone to custom, on the iPhone watch app, it will not let me change the default email from iCloud, yet everywhere else on the iPhone settings the default is correct.

Did you make any changes to get this to work properly, or did it just resolve itself?
 
Last edited: