Watch Thinks All Music is ABBA...?

Nekomichi

macrumors regular
Original poster
Sep 20, 2016
114
72
I'm having this weird issue with my Apple Watch and album art, was wondering if anyone could shed some light on it. But first, here are the specs of the involved devices:

- MacBook Pro (MacOS Sierra 10.12.6)
- iTunes 12.7
- iPhone 7 (iOS 11.1 Public Beta 3)
- Apple Watch Series 3 (Wi-Fi, WatchOS 4.0)

I originally had music synced onto my Watch and everything was working perfectly, however due to an iTunes-related mishap, all of the music on my iPhone got erased and subsequently so did the music on my Apple Watch. I was able to re-sync the music back onto my iPhone and everything was fine on that side, but when I synced some albums from my iPhone to my Apple Watch, half of the albums had their artwork replaced with an ABBA picture.

Here's what an example album looks like when displayed correctly on my iPhone:
IMG_2211.PNG

And here's what the same album looks like when displayed on my Apple Watch:
IMG_2210.PNG

What's weird is that I don't have any ABBA albums on my Watch, iPhone, or even iTunes library. Half of the albums on my Watch are now displaying this cover art instead of their correct image.

I have tried rebooting all 3 devices, erasing the music from my Watch, iPhone, and iTunes library, re-adding the music on all three, even manually inspecting each track's details in iTunes to verify that none of them had actually been set to the ABBA cover. (I even removed every track in my iTunes library, deleted iTunes' artwork cache, and then re-imported them)

I'm not sure what could be the cause of this. Is this a bug due to my iPhone running a public beta? (and if so, has anyone else running 11.1b3 also encountered this before?)
 


Nekomichi

macrumors regular
Original poster
Sep 20, 2016
114
72
Oh you must be broken hearted, oh with the way this started

My My,

How will you ever let it go?

Seriously though, check your iTunes library. Are the albums themselves all screwy on the computer? Failing that, delete that Chopin music and download some Steel Panther. Thank me later.
I’ve checked the music on iTunes and my iPhone, and the artwork is fine on both. Oh well - guess this is my life now...
 

eVolcre

macrumors 68000
Jan 7, 2003
1,984
565
I’ve checked the music on iTunes and my iPhone, and the artwork is fine on both. Oh well - guess this is my life now...
You’re such a trooper ...

... supertrooper!

:) I I’ll stop. Strange though. Have you tried deleting the music on the watch and just syncing it again? (Actually you did I just scrolled up )
 

pika2000

macrumors 603
Jun 22, 2007
5,363
4,589
This is probably one of the best thread in this forum. LOL.
To OP, have you tried resetting the AW and configure it from scratch? Maybe it has some corrupted database for the album art.
 
  • Like
Reactions: HeathH and eVolcre

eVolcre

macrumors 68000
Jan 7, 2003
1,984
565
This is probably one of the best thread in this forum. LOL.
To OP, have you tried resetting the AW and configure it from scratch? Maybe it has some corrupted database for the album art.
Every single time it pops up im laughing. Actually there’s another one in the watch forum. Some guy couldn’t get his stands circles to complete because he’d wake up at 4 in the afternoon and there aren’t ten hours in the day!!!! Hahahah

That one was absurd. Here I actually feel bad for the OP but it’s still hilarious
 

Nekomichi

macrumors regular
Original poster
Sep 20, 2016
114
72
I think a possible reason for this is that the watch could be trying to pull the album artwork from a cache instead of actually looking at the embedded artwork. I could unpair and then re-pair my watch but I’m too lazy and will probably do it some other time.
 

HeathH

macrumors regular
Apr 21, 2010
138
57
Honolulu, HI
I recently had to unpair and re-pair as a new watch. Wasn’t that bad actually.

I was having odd errors with the music app. Wasn’t this error (unfortunately), but mine wouldn't accept any controls. Once it started playing music wouldn’t stop no matter what you did until shut it off totally.

Re-pairing fixed this and seems overall running much better (S0 SSSB).
 
Last edited:
  • Like
Reactions: Nekomichi

igrover

macrumors regular
Jun 9, 2007
233
136
Possible. I STILL have the black/red U2 special edition ipod. Who's old enough to remember THAT? Christmas present circa 2003 (???)
I have one too! Also my dentist's office has one attached to an old iHome speaker. The receptionist says all the kids look at it and do not know how to use it.