Watch update 5.2.1

Discussion in 'Apple Watch' started by bigrids, May 14, 2019.

  1. bigrids macrumors newbie

    bigrids

    Joined:
    Nov 27, 2017
    #1
    I'm having problems trying to do the latest update. Phone keeps saying I can resume download when I am connected to wifi. I am connected so don't know what to do next. I have tried switching phone and watch off and back on again. The download restarts but soon stops.

    Anyone else had this p[roblem?
     
  2. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #2
    I have had that in the past - i just kept trying and eventually it worked - it takes a long time to update sometimes.

    Make sure both the watch and the iPhone are plugged in to a power source while updating and don't mess with them while updating - keep them close together - I think it is blue tooth that does the update to the watch

    Sorry not the silver bullet you are looking for - maybe someone else has an update trick or info that I don't have and will share it

    It does take a while to update
     
  3. bigrids thread starter macrumors newbie

    bigrids

    Joined:
    Nov 27, 2017
    #3
    It's sorted now. I went to Apple website and they suggested deleting the update file and then trying again. Did that and it went through OK
     
  4. Smoothie, May 14, 2019
    Last edited: May 14, 2019

    Smoothie macrumors 6502a

    Joined:
    Jun 23, 2007
    Location:
    California
    #4
    I’m having the same problem. Where do you find the update file to delete it?

    Edit: The watch eventually updated, although it took a loooong time.
     

Share This Page

3 May 14, 2019