WatchOS 3

Discussion in 'Apple Watch' started by robduckett14, Sep 14, 2016.

  1. robduckett14 macrumors member

    Joined:
    Jul 31, 2015
    #1
    Anybody else's watch feel slower after update to latest os. It seems like the update made my watch even slower the load times are horrendous. When i open the app there is a circle with the icon in it of the app and takes a very long time to open, of course it opens faster once the app is open. But I am not seeing any of the improvements that were mentioned at this past WWDC. I have hard reset as some users on this forum have suggested but no luck if anybody has any information or can help it would be much appreciated. Thanks
     
  2. sean000 macrumors 65816

    sean000

    Joined:
    Jul 16, 2015
    Location:
    Bellingham, WA
    #2
    I had the same problem this morning. I upgraded to iOS 10 and Watch OS 3 last night, and after the upgrade things were working well as far as I can remember. This morning I could not get either of my weather apps to load (Dark Sky or Carrot). My complications seemed to work, but when I went to the dock everything seemed to hang. Fantastical crashed and many apps would just display the circle with the app icon spinning... except form e the apps would never actually open. I restarted the watch and since then things have behaved just fine.

    I do have a number of third party apps in the dock, and at least a couple of them had updates today. I'm guessing some apps still need to be optimized for the new OS. Fantastical was one of my best performing apps on Watch OS2, and on OS3 it's got some lag if I actually open the watch app (or access it from the dock).

    I did not do a hard reset. I simply powered off the watch for 15 seconds or so and turned it back on. I have not seen the circle icons again all day. The docked apps are mostly very fast (although I hope Fantastical gets faster with an update). I think there will be a lot of app updates over the next few weeks.

    Sean
     
  3. robduckett14, Sep 15, 2016
    Last edited: Sep 15, 2016

    robduckett14 thread starter macrumors member

    Joined:
    Jul 31, 2015
    #3
    I tried just turning it off but still having the same issue with the loading times and the circle when first opened. I'm not sure what it could be. I would have thought that at least the stock apps would load a bit quicker but they have similar times as the third party apps so I am assuming that it is something with the system maybe a restore is needed and a fresh install.
     

Share This Page