Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

b4ulaf

macrumors member
Original poster
Jul 3, 2008
33
13
Atlanta, GA
Starting on the previous beta, my Apple Watch S4 does not work with iMessages.

When I receive an iMessage on my iPhone, it appears in the Messages app on my watch (sometimes blue, sometimes green), and will only allow me to respond via SMS.

I've tried the following:
  • Checked all settings on both iPhone and watch and cannot find anything that would cause this.
  • Tried turning iMessage off and back on via iPhone
  • Un-paired and set up as a new watch (full reset)
Can someone help me?

P.S. I submitted a bug report in the feedback app regarding this.
 

crjackson2134

macrumors 601
Mar 6, 2013
4,752
1,909
Charlotte, NC
Mine was doing this a couple of times after an update. A hard reset of the watch/phone fixed it for me in both cases. It has become a regular part of my update process to do a normal reboot of watch/phone after an update, then followed up with a hard reset of both. I’ve not had the problem again after following this regime.
 

StumpyBloke

macrumors 68040
Apr 21, 2012
3,689
3,354
England
Just wondering if you guys still have quick replies on your messages on your watches? I have none at all on 6.1 beta.
 

jonlon15

macrumors newbie
Mar 4, 2010
3
0
Starting on the previous beta, my Apple Watch S4 does not work with iMessages.

When I receive an iMessage on my iPhone, it appears in the Messages app on my watch (sometimes blue, sometimes green), and will only allow me to respond via SMS.

I've tried the following:
  • Checked all settings on both iPhone and watch and cannot find anything that would cause this.
  • Tried turning iMessage off and back on via iPhone
  • Un-paired and set up as a new watch (full reset)
Can someone help me?

P.S. I submitted a bug report in the feedback app regarding this.
Have you found a solution to this issue? I am still experiencing the problem on the public watchOS 6.1 release. I have tried these same troubleshooting steps, except for unpairing and setting up as a new watch (setting up Apple Pay all over again is such a nuisance)
 

b4ulaf

macrumors member
Original poster
Jul 3, 2008
33
13
Atlanta, GA
Yes, I have! When the GM versions were released, I updated everything and then called Apple. The only thing that fixed my issue was doing the following:
-Turn Apple Watch OFF
-On iPhone, go to Settings > General > Reset > Reset All Settings
-Follow prompts, iPhone will turn off and back on
-On iPhone, go to Settings > Messages - You will probably need to re-sign into your Apple account for iMessage. Ensure all other settings on this page are accurate.
-Turn Apple Watch back on

This completely fixed my issue; however you will need to re-configure all of your settings (such as notification preferences, wallpaper, etc.). It is a pain to reset everything, but for me, it was worth having iMessage working again on my watch.

I hope this works for you too! Good luck!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.