Water damaged iPhone 4S

Discussion in 'iPhone Tips, Help and Troubleshooting' started by reubenk, Aug 1, 2013.

  1. reubenk macrumors newbie

    Joined:
    Aug 1, 2013
    #1
    Hi!

    I recently water damaged my iPhone 4S. I left the phone in rice for 2 days and just tried to charge it again.

    It now loads the Apple Logo, but after that the screen goes blank.
    The weird thing is that iTunes discovers the iPhone and it lets me check everything as normal including photos I have within the phone.

    I then took a series of screen shots, and it shows up on my MacBook the phones software functioning as normal, yet the blank screen persists.

    When I do a hard-ware reset, the phone turns off as normal, loads the Apple screen, then just goes blank again and has been doing this for some time..

    Does anyone know the solution for this? Im presuming it can't be the screen since the Apple logo loads, im wondering could it be a software issue?

    Ive been trying to restore my iPhone but it keeps getting stuck and says 'The Network Timed Out'

    Thanks alot in advance guys!
     
  2. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
  3. reubenk thread starter macrumors newbie

    Joined:
    Aug 1, 2013
    #3
    Update.

    I did as Carlanga said and it worked, kind of.
    So I restored using another computer and the screen loaded and all was fine. I resored it at my work iMac and didn't bring my SIM Card in with me, and the screen loaded fine (even though it would occasionally flicker).

    When I got home i put the SIM Card into the phone and plugged it into my MBP that has the backup of my iPhone. It successfully restored it, but the phone went back to normal again with no screen showing up, even though people can still call me (I have to guess where the buttons are on the screen!!)

    When i hard reset, the Apple Logo shows up as per normal, but then the screen goes blank and the saga continues..

    Would REALLY appreciate some more help on this guys!

    Thanks
     
  4. DGPMaluco macrumors regular

    Joined:
    Nov 16, 2012
    #4
    You have the answer, don't put in your backup and let's see how it goes from there
     
  5. reubenk thread starter macrumors newbie

    Joined:
    Aug 1, 2013
    #5
    Just came on to tell everyone how I finally managed to fix this problem.

    Turns out the old Backup setting had iPhone screen waaaay dimmed down, So I had to constantly take screen shots from the iPhone to the Macbook and work my way through the settings til I got to the adjust brightness section. Sure enough when I adjusted the brightness the phone lit up!
     
  6. stormchaser macrumors 6502

    stormchaser

    Joined:
    Mar 4, 2010
    Location:
    UK
  7. Lord Hamsa macrumors 6502a

    Joined:
    Jul 16, 2013
    #7
    I don't know if the brightness setting was a problem in and of itself, because one of my 6-year-old twins dropped an old 3GS (handed down to the kids and used as a bulky iPod rather than as a iPhone) into water this past week. Did the rice treatment and I'm getting pretty much the exact same visual symptoms (Apple logo then apparently blank screen). I'm going to try the sync to a different iTunes account/computer advice when I get the chance.

    What I do know is that due to the screen protector on the Otterbox the phone was in, brightness on the phone (and on any backup) was cranked to max.
     
  8. Lord Hamsa macrumors 6502a

    Joined:
    Jul 16, 2013
    #8
    Update: Hooking the 3GS up to to Mac under a different account seemed to work - iTunes "saw" the device and after getting a bit of a charge back, the phone was responsive again, with all of the data intact.

    Three problems remain, though:

    1) Despite not being hooked up to anything, it will occasionally display the "charging is not supported with this device" message. I'm hoping this is just dust/debris from the rice and a good blast of air to clean out the dock connector will clear that up.

    2) Sound. There isn't any. The volume sliders just aren't there, or if they are, it's a blank bar without a slider. However, under the Settings->Sounds menu, I can get it to play system sounds when adjusting the volume control for the ringer, and they play just fine. Headphones work.

    3) General sluggishness. I haven't really checked out the apps yet, other than listening for sound, but it's not registering clicks on the home button as easily as I remember.

    Any thoughts? I've considered just wiping the whole thing with a factory reset and starting from scratch, but anything less drastic would be appreciated.
     

Share This Page