Way to get Safari to display light font variants?

Discussion in 'Web Design and Development' started by Makosuke, Feb 6, 2008.

  1. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #1
    I was working on a site that the designer would, given total typographic freedom, use Gill Sans Light on. I figure why not just specify it as the first choice, then leave some more common sans-serif fallbacks for the large majority of people who don't have it installed. No harm in that.

    Except I realized after wondering why the site was previewing drastically different in Safari and Camino that, while Camino recognizes "Gill Sans Light" as the light variant of Gill Sans, Safari treats it as if it were its own font, which of course doesn't exist, so it uses the next fallback.

    Now, I can specify "Gill Sans", which Safari (and Camino) does recognize, but I can't figure out any way to specify the Light variant of it--font-weight: light, font-weight: lighter, font-style: light, etc don't do anything.

    Is there something obvious I'm missing here? How do I get Safari to use the light version?
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
  3. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    Thanks for the tip, angelwatt--I missed that last year, and it's a pretty nifty addition.

    Near certain it won't do me any good, though; since OSX treats Light as a variant of Gill Sans, and there apparently isn't any way to tell it to use that variant in "common" CSS on systems that already have Gill Sans installed, loading the font via @font-face is just going to put me in the same situation unless I can come up with a version that is recognized as a unique typeface instead of a variant of the family.

    Guess I could find a free font that looks similar, specify that via @font-face, then fallback to Gill Sans Light for Gecko-based browsers on the Mac (or the odd Windows user with Gill Sans Light around).

    Dang.
     
  4. elppa macrumors 68040

    elppa

    Joined:
    Nov 26, 2003
    #4
    Try -Light

    As in:

    font-family: "GillSans-Light", sans-serif;

    To find others, open font book, click the font you want and then choose preview > show font info. The "full name" is the one you need to use.
     
  5. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #5
    Nice. I tried it in Safari and seems to work. Though Firefox doesn't recognize that name. It does recognize the full name so,

    font-family: "GillSans-Light", "Gill Sans Light", sans-serif;

    looks to cover most Mac browsers. Though as a note, it's the PostScript Name you want, not the Full Name, at least for Safari.
     
  6. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #6
    Nice!

    This works, with one unfortunate little caveat. If you later use a strong tag or otherwise specify bold, instead of bumping it to "Regular" weight, or even going all the way to Bold, it instead drops to the next option in the list of fonts. You can go a step further and specify:
    Code:
    font-family: "Gill Sans Light","GillSans-Light", "Gill Sans", sans-serif;
    ...but if you don't, you get the fallback sans-serif instead.

    It's funny, because this is a variant of a Safari issue (not bug, just nonstandard behavior) that I ran across years ago; if you italicized text in a font that had no proper italics version, the font would switch to the next fallback and use that instead of using a pseudo-italics version. This caused some weird looking stuff on occasion, but apparently is no longer the case with "normal" text in Webkit 3, since my demo page from way back when now renders normally.

    It's funny because while it looks like the more general version of this is fixed, this somewhat more involved font specification remains the old way.

    I assume it's because specifying "GillSans-Light" is causing Safari to render text using a more strict font mode, where it won't pseudo-italicize/bold text if such a font variant doesn't exist.
     

Share This Page