WD 2TB My Passpost does not show up on MBA

Discussion in 'MacBook Air' started by kchirayus, Jan 8, 2013.

  1. kchirayus macrumors newbie

    Jan 8, 2013
    I had this external hard drive for 6 months now. Today I was using my computer like usual with the hard drive plugged in when suddenly it shows a dialog saying that my external hard drive has been incorrectly removed.

    I haven't been able to use my hard drive since. When I plug it in, there's no running noise, the hard drive doesn't show up on the desktop or in the disk utilities. The LED activity light on the hard drive is out too.

    Please help, lots of important data on it.
  2. simsaladimbamba

    Nov 28, 2010
    Either the enclosure or the HDD itself could have died.

    You could remove the HDD from its enclosure and try it in a different one (USB <> SATA adapters can be had for 10 €) and see, if that works.

    If that does not work, you have to contact WD about your warranty. I do not know, what WD's warranty says about data recovery or similar, but I presume, that it is not covered and they will probably just send you a replacement.

    If you have an experienced computer repair store nearby, you could also employ their help.

    And for the future, as backing up is important:
  3. goinskiing macrumors 6502a


    Jun 25, 2008
    Meridian, ID
    Just bought exactly one of these the other day and it works fine for my MBA. I store my entire Aperture library on it backed up to a 4TB drive at home.
  4. JonLa macrumors 6502

    Dec 22, 2009
    Go into Disk Utility and see if it's picked up the drive but is showing as unmounted. If so, try to mount it, also try to Verify Disk.
  5. mctintin, Jan 9, 2013
    Last edited: Jan 9, 2013

    mctintin macrumors newbie

    Jan 9, 2013
    I know it might be obvious, but have you tried a new lead for the HDD in case it's the cause of the failure.

    The other option have you tried some other device in the USB, in case the port has lost power
  6. halledise macrumors 65816

    May 7, 2009
    Hamilton Island, Whitsundays, QLD Australia
    I stay well away from Western Digital products.
    their controllers are 'integrated' so recovery of data is nigh impossible when they stuff up.

Share This Page