WD 3tb external having efi problems

Discussion in 'Mac Accessories' started by vigeoh, Mar 7, 2014.

  1. vigeoh macrumors newbie

    Joined:
    Mar 22, 2009
    #1
    My 3tb western digital hd was having very slow transfer rate today so I ran verify disk permission and I was given the message "external the partition map needs to be repaired because there’s a problem with the efi system partition’s file system" does this mean my hard drive is on the way out and I should transfer data somewhere asap? I was given the same message when i tried to repair disk.

    information about set up:
    MBPR
    mavericks
    3tb western digital hard drive with 100gb partitioned to windows

    Thanks a lot,

    V
     
  2. vigeoh, Mar 7, 2014
    Last edited: Mar 7, 2014

    vigeoh thread starter macrumors newbie

    Joined:
    Mar 22, 2009
    #2
    After a restart and rerunning disk utility I now get the message "this disk doesn’t contain an ego system partition. if you want to start up your computer with this disk or a include it in a raid set, back up your data and partition this disk"

    i do not want to start my computer up this drive nor is it part of a raid set up...

    ----------

    another restart and disk utility appears to be running with no problems, but still, can anyone tell me why this happened? should i be worried about the health of my hard drive?


    ---------

    transfer rate is still very slow
     

Share This Page