WD 500GB-1TB HDD Snow Leopard problems?

Discussion in 'MacBook Pro' started by Saosin, Nov 6, 2009.

  1. Saosin macrumors newbie

    Joined:
    Sep 2, 2009
    #1
    Hi all!

    I recently purchased one of Western Digital's new 12.5mm drives, the 750GB version with model no. WD7500KEVT.

    I've previously replaced my DVD burner with an Intel X25-M G2 80GB with no problems whatsoever. I put the 750GB drive where the stock 160GB used to reside (because there's better vibration damping there than in the DVD caddy).

    First thing I did after turning on my MBP was to copy about 160GB of movies from an external drive to the new WD drive. 2/3 through the transfer just paused with no explanation whatsoever. Nothing happened for about 30 minutes or so so I cancelled the transfer. After this the drive was no longer working properly. Sometimes I could transfer a few GBs of files but mostly the drive wouldn't respond at all with the transfer window stuck at "preparing to copy files" or "zero kb of X GBs transferred".

    I've tried just about anything but the drive refuses to work. This is some of the stuff I've tried without success:
    1. Erase and partition in Disk Utility (which btw hangs most of the time when the drive is connected) many, many times
    2. Removing the battery connector for a few minutes (guess this is the same as removing the CMOS battery on a PC motherboard?)
    3. Clean install of Snow Leopard
    4. Testing the drive without any of the Snow Leopard updates applied, including the "pausing HDD" patch
    5. Edit: Including Performance Update 1.0

    Inserting the drive into a Windows 7 PC, the drive works flawlessly, at least for the 15 minutes or so that I tried it.

    I even bought the 500GB version (WD5000BEVT) but I got exactly the same problems with that drive.

    I'm writing all this because I want to see if anyone else have heard about any problems with these drives in Snow Leopard and if anyone knows of a fix.

    Thanks in advance!
     
  2. Relznuk macrumors 6502

    Relznuk

    Joined:
    Sep 27, 2009
    Location:
    UT, USA
  3. Saosin thread starter macrumors newbie

    Joined:
    Sep 2, 2009
    #3
    Already tried that :(

    Btw, I don't think I made this clear - the 160GB Hitachi HDD that came with the Mac have none of these problems.
     
  4. screensaver400 macrumors 6502a

    Joined:
    Jan 28, 2005
    #4
    Sounds like a problem with the laptop.

    Can you install Windows 7 with Boot Camp? Try copying the files there.

    If it works, you have some kind of software problem. If it doesn't, you have a hardware or firmware issue.

    I suspect it's a hardware problem or perhaps corrupted firmware. A lot of people have used the WD 500gb drive in your
    MacBook Pro successfully.

    Unfortunately Apple only guarantees the machine will work "as shipped." While installing an aftermarket drive won't void your warranty, Apple probably won't fix a problem that only presents itself with aftermarket products.
     
  5. Cave Man macrumors 604

    Cave Man

    #5
    Did you initialize the drive with HFS+ and GUID partition table?
     
  6. Saosin thread starter macrumors newbie

    Joined:
    Sep 2, 2009
    #6
    Yup!

    Edit: Sorry, missed your post screensaver400. That's really g*y if true. I'm coming from Dell's super awesome support thinking that MBP's have so great build quality that I wouldn't have to worry about Apple's support not being as good.

    I thought Boot Camp wasn't supported with W7?

    Too bad I'm so in love with my Mac that returning to a Windows-based computer isn't really an alternative :(
     
  7. Takashi macrumors regular

    Joined:
    Oct 26, 2009
    #7
    Installed WD 500 GB HD into my MBP 13" with no issues encountered. Note: I only had 30 GB of stuff in my old HD when I did the upgrade.
     

Share This Page