WD Black2 Problem - WD Support Is Awful

Discussion in 'MacBook Pro' started by drummingcraig, Apr 20, 2015.

  1. drummingcraig macrumors 6502a

    drummingcraig

    Joined:
    Sep 19, 2007
    Location:
    "Armpit of the South"
    #1
    [deep breath...not going to rant]

    I purchased a WD Black Dual Drive for my Macbook Pro 5,1 and installed it, being sure to follow all of the instructions provided by WD for install on a Mac. I want to set it up to run as a Fusion drive and WD provides two configuration scripts (one for Fusion setup and one for HDD/SSD setup). Problem is that when I ran the script for the Fusion config it thru an error which read "The action "Run Shell Script" encountered an error. Check the action's properties and try running the workflow again" (also see attached screenshot).

    Here is where I am at currently:
    • Disk Utility displays the drive as "Core Storage" with a single partition named "WD Black2". I believe this is how a Fusion drive should look in DU.
    • When I use the boot disk select feature (booting while holding "option") it comes up as TWO identical disk images which both are named "WD Black 2" (see attached screenshot).
    • When I boot off of my old HD (which is running OSX 10.8) the WD drive mounts as a single volume drive with the regualr disk icon named WD Black 2.
    • If I run "About This Mac...' the storage tab displays the single disk icon for the WD drive (1.12 TB SSD), but then shows two 1.12 TB volumes which are both identical (see attached screenshot).

    I should also add, that I know the drive works as I was able to install 10.10 on it (I had to pick one of the two identical drive images though) and it ran great. When I booted off of it into Yosemite it only took about 25 seconds. I just don't want to move forward migrating stuff over with this double image bug as that is sure to cause me headaches down the road.

    I am really hoping someone here sees this and can offer some ideas. WD Support only seems capable of sending me the exact same .pdf instructions which I followed initially. I am at wits end with them.

    That said, any help would be greatly appreciated.
     

    Attached Files:

  2. duervo macrumors 68000

    duervo

    Joined:
    Feb 5, 2011
    #2
    Check console.app for errors related to the drive setup script that you ran. Look for the timestamp that's close to when you attempted the setup. There's most likely one or more hints towards what the problem really is around there somewhere.
     
  3. justin77 macrumors newbie

    Joined:
    Mar 31, 2015
    #3
    Yeah, don't worry. It's just because the computer knows that there are two drives, but the tool we used from WD tells the computer that they're both SSD. It's kind of annoying, because I'd actually like the computer to know that the 1TB is a HDD, but whatever. I've setup 3 drives together in CoreStorage and they haven't given me trouble thus far.
     

Share This Page