WD Caviar Green issues with G5

Discussion in 'PowerPC Macs' started by roddenberry, May 5, 2012.

  1. roddenberry macrumors newbie

    Jan 25, 2009
    Here's an interesting one for you folks! I have friend with a Mac G5 tower dual 1.8 GHz (M9393LL/A) with 3 GB RAM. It had a small-ish 200 GB drive so he decided to upgrade it with a 2TB drive to accomodate his ever-expanding music collection.

    I have done this with my own G5 tower a year ago, when I installed a Western Digital Caviar Green 1 TB drive in it and it has been running 10.5 flawlessly ever since.

    So I bought him a WD Caviar Green 2 TB drive, because of the good experience I had with this drive. We proceeded to install the hard disk and up to the installation of Mac OS 10.5, everything went well and the new drive booted without problems. Then I ran Software Update to get his machine up to specs and after the installation finished, the drive stubbornly refused to boot, even though it was visible on the desktop. I tried the Option Start and only the old drive was visible, so I tried with Startup disk, it showed the new drive, but even though I selected it, it would boot again and again on the old drive. Disconnecting the old drive gives me a Question Mark folder.

    I took the new drive and it succesfully booted several times on my MacBook pro laptop using a SATA/USB adapter! Aargh! So the drives runs on another computer, but not on his. Before deleting everything and starting over, I wanted to make sure I didn't do anything wrong because it's a LOOONG process!

    I desperation, I partitioned the drive in two (2x950GB) and the damn thing doesn't even show up on the desktop or in Disk Utility after I reboot. I'm at my wits end I have to admit, I have no idea what to do (aside from bringing the drive back to the store).

    I was wondering if any of you guys (and gals) ever had problems or compatibility issues with G5 towers and WD Caviar Green drives?

    Thanks! - Robert
  2. drlunanerd macrumors 68000


    Feb 14, 2004
    This may have something to do with the partition scheme on the drive.

    It needs to be Apple Partition Map to reliably boot on the G5.
    You may have inadvertently partitioned it as GPT, which is why it's booting OK on your Intel MacBook Pro.

    I'd check that first in Disk Utility.

    Also, to speed up installing 10.5, you could make a boot disk from the installation DVD using a USB key or an external drive. It really saves time.
  3. drorpheus macrumors regular

    Nov 20, 2010
    not sure if youve already done all this or not, but when you formatted it, did you use APM or GUID, APM is needed to boot from PPC wher GUID is needed to boot from Intel. Also Ive being using the 1tb blacks since 2008, but i know last years WD drives are set at SATA 3 and need to be jumpered down on pins 5&6 to bring it down to SATA 1, but if you were able to get to where you were i dont think the jumper should be a problem. Only other thing i can think of is that some how the green powering down cycle is somehow acting up, but i dont know if you can changed that variable on the green drives or not.
  4. roddenberry thread starter macrumors newbie

    Jan 25, 2009
    Yes it has been partitioned and formatted using APM. I've tried everything, and it still refuses to boot. I'll try the jumper at pins 5/6 even though the WDC manual recommends not to. Here's what I found at:


    "OPT1: 150 MB/s data transfer speed enabled or disabled. Default
    setting is disabled. To enable 150 MB/s data transfer speed, place
    a jumper on pins 5–6."

    Isn't this a typo in the instructions? Shouldn't this be 1.5 GB/s?

    But since the drive in my own G5 never gave me a hint of trouble and is pretty much the same generation as this 2TB drive, I think more and more that it's just plain defective.

  5. Intell macrumors P6


    Jan 24, 2010
    I have a WD Green drive in my PowerMac G5. It would only work reliably if the SATA I jumper was set. Otherwise, it would sometime fail to boot or see the drive.

    That isn't a typo. 150 megabytes per second is about the fastest SATA I can move data. SATA I runs at 1.5 gigabits per second.

    And for future reference, an AMP formatted drive is bootable externally on Intell Macs.
  6. Hrududu macrumors 68020


    Jul 25, 2008
    Central US
    I wouldn't boot of a WD Green drive if you paid me. Those things are terrible for performance. They're fine for dumping lots of storage, but as a primary boot drive they are simply horrible. Why not install the OS on his 200GB drive or a new 7200rpm Black drive and use the green as extra storage?
  7. roddenberry thread starter macrumors newbie

    Jan 25, 2009

    That did it!!!

    Thanks a million guys, the jumper on pins 5/6 was the solution! Now the drive is rock stable and boots like a charm.

    I updated the OS and the machine boots perfectly every time. But as I mentioned, my 1TB drive has been in my own G5 for about a year, and never failed me. Since my friend's usage will be mostly image editing and as a massive iTunes music player for his sound system, this drive will suit him well!

    Thanks all for your help. Most appreciated.

  8. Erik2v macrumors newbie

    Jun 9, 2004
    Glad I found this thread!

    I spent *ALL* morning, over 7 hours fighting this problem.

    Thought it was OSX Server failing to install, then maybe my G5 dying, then maybe cables... you name it, I troubleshot it.

    Finally did a search for my BRAND NEW (2) - WD Green 1 TB drives - with a G5 combination, and finally found this!

    WOW. I had drives that would fail to take an install, fail to boot, periodically disappear from the DISC UTILITY list. What a PAIN this was.

    Sure enough, jumping 5/6 not only made SENSE, but seemed to clear up my PERIODICALLY MISSING disks. Doing an install next.

    Whoever found out about 5/6 jumper - THANK YOU SO MUCH!

  9. zen.state macrumors 68020


    Mar 13, 2005
    It's listed with a diagram right on the drive label.
  10. Erik2v macrumors newbie

    Jun 9, 2004
    "It's listed with a diagram right on the drive label."

    Yes, the jumper settings can be found... I even checked the website after reading the original messages. "5/6" set OPT1 enable, which actives 1.5GB transfer speed.

    Maybe it's just me, but it wasn't obvious that the reason the drive would *sometimes* disappear or fail to boot was because it's a SATA3 drive and wasn't enabled (by default) to run on SATA1 interfaces.

    The installation manual that shipped in the box is only a quick start guide... one page written in about 10 languages. No discussion about setting jumpers at all. Just unpacking instructions.

    I went through multiple 45 minute installs that would fail to boot, but took an install without apparent problems.

    Maybe I should rephrase my thanks here - how about this :

    "To whomever figured out the reason this drive wouldn't work on a G5 is due to the fact the drive ships *without* SATA1 speed enabled, and you need to enable it by jumping 5/6 on the drive to enable OPT1 - THANK YOU!"

    I guess that person is Intell. He saved me a trip back to Best Buy and likely several attempts to swap out other drives.
  11. timVZ macrumors newbie

    Jul 20, 2012
    Caviar green 1tb x 2

    Sorry to jump in on this... I've got 2 caviar green 1tb's and nether show up on my PowerMac 1.6ghz. Trying to make it a server for home. Should I jump pins 5-6 or is there something else? Read a lot of differing opinions on this. I've seen the sonnet card but don't need that much space.
  12. Intell macrumors P6


    Jan 24, 2010

Share This Page