WD Digital won't mount.

Discussion in 'Mac Accessories' started by stlwx21, Jan 31, 2008.

  1. stlwx21 macrumors member

    Joined:
    Jan 24, 2008
    #1
    I am having problem getting my 500GB Western Digital external HD to work. The green lights on the HD are on, and the drive appears in the Disk Utility. I tried to "Repair Disk" but it did not work.

    It is only USB 2.0 and not a firewire drive. This is would be the first time I have used it since the Leopard upgrade (Archive and Install), but it did not work.

    Any tips or hints as to what I can do to get this working?
     
  2. ErikAndre macrumors 6502a

    ErikAndre

    Joined:
    Nov 14, 2007
    Location:
    Florida
    #2
    Go to Disk Utility and try Partioning the drive and formatting it. I've had to do this with all my WD drives. The drive should show there. Often they won't show in the finder until you partition/format it.
     
  3. stlwx21 thread starter macrumors member

    Joined:
    Jan 24, 2008
    #3
    Will I lose the data on the drive after doing that? It is the only place where I have my info backed up.
     
  4. stlwx21 thread starter macrumors member

    Joined:
    Jan 24, 2008
    #4
    Well, I went to the Disk Utility and tried to mount it from there and it would not successfully mount.
     
  5. harcosparky macrumors 68020

    Joined:
    Jan 14, 2008
    #5
    This may sound stupid .....

    Have you tried restarting the computer leaving the USB drive plugged in as it boots up.

    I vaguely recall losing a drive and rebooting got it back, I believe what caused my situation was removing the USB drive before properly ejecting it.
     

Share This Page