WD Drive Utilities 2.05.18

Discussion in 'macOS Sierra (10.12)' started by loekf, Nov 6, 2016.

  1. loekf macrumors 6502a

    loekf

    Joined:
    Mar 23, 2015
    Location:
    Nijmegen, The Netherlands
    #1
    I have three external My Book drives: one for time machine, one for media back-ups and a My Book Duo in RAID0.

    Western Digital has a utility called "WD Drive Utilities" you can use to check the SMART status, change the RAID setup (if applicable) and perform low-level checks.

    It worked fine on Yosimite, but things started go bad when El Cap came out. With El Cap, you typically see RAID errors for a single disk My Book (which doesn't run at all in RAID mode, so makes no sense). So I uninstalled it.

    When Sierra came out, WD also released a new version, so I gave it a try again:

    - RAID errors are reported for the Duo, while there's nothing wrong with the drive itself.
    - Time Machine errors, like can't write to a folder, occur.
    - Data on my back-up drive or my back-up drive went bad. I think it was still mounted (or got mounted when connected), but not visible at all in Finder. Even Disk Utility refused to see the drive anymore. After removing the WD Drive Utilities and reboot, the drive was still invisible. When I checked under Windows, the data was still there, but the exFAT file system damaged. Now has Windows 10 issues with exFAT formatted drives under macOS regular issues (best thing is to format under Windows, use MBR as partition), but this was real strange. After a reformat under Windows (as exFAT) it worked again.

    Might sound trivial, but don't install this utility. It might work for a few days, but you might get data losses.
     
  2. Zab the Fab macrumors member

    Zab the Fab

    Joined:
    Nov 26, 2003
    #2
    My "My Book Studio Edition II" (which is a duo hard drive box), shows up fine in Sierra, but I have had data loss. Mp3 files gone missing a lot.

    I would like to change the RAID configuration but the WD Drive Utilities does not recognise any of my drives?
     
  3. stooovie macrumors 6502a

    Joined:
    Nov 21, 2010
    #3
    This utility has never done anything useful, it's typical hardware manufacturer bloatware.
     

Share This Page