WD Drive won't mount but shows up in Disk Utility

Discussion in 'Mac Accessories' started by csand, Oct 22, 2009.

  1. csand macrumors newbie

    Joined:
    Oct 22, 2009
    #1
    I'm trying to access some files for a client on a Western Digital external firewire/USB drive on my MacBook Pro. The drive will not mount in Finder. The upper level drive shows up in Disk Utility, but the partition of the disk I would like to mount (the only partition on the drive) is greyed out. I know that it's formatted for a Mac and has been accessed recently.

    In Disk Utility, when trying to mount or eject, the an error comes up saying to use first aid. Verify and Repair Disk don't change anything though.

    Any thoughts? Thanks.
     
  2. skarocks47 macrumors member

    Joined:
    Sep 26, 2008
    #2
    Was the drive originally used with a Windows computer? If so its probally NTFS and Macs cant natively read such drives.
     
  3. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #3
    That would be incorrect. Macs can read NTFS but cannot write to them. Plus the OP said that it was formatted for Mac (HFS+) and was accessed recently.

    The drive sounds like it's corrupt. I would look into data recovery software since it will mount in Disk Utility. Hopefully the data is still recoverable.
     
  4. skarocks47 macrumors member

    Joined:
    Sep 26, 2008
    #4
    Well i guess i need to read better. I thought macs cant read them natively. You need some sort of program or driver.


    But back to subject. I agree with skorpien. It sounds like its corrupt.
     
  5. PaulStL macrumors newbie

    Joined:
    Oct 23, 2009
    #5
    Possible Solutions

    I'm familiar with your situation. Your problem probably has to do with "Enable Owners". In Disk Utility, get info on your drive and see if Enable Owners=no. If it's no, I believe that's why you can't mount it. Mine changed to "no" after I tried to run software off off a non-startup drive. The software asked me for my serial number and when I entered it, it started returning errors. Thinking a reboot would solve the problem, I tried restarting only to have that fail and my drive report enable owners=no.

    If you google "enable owner", you will find some solutions but they didn't work for me. I've run disk util, rebuilt the drive using Drive Genius and tried the solutions I found on the net but nothing has worked.

    Good luck and if you find a solution, please post.

    Paul
     
  6. csand thread starter macrumors newbie

    Joined:
    Oct 22, 2009
    #6
    Solution, though no cheap

    The only sure solution I could figure out was to
    1) buy a new hard drive with same or more space
    2) download Data Rescue 3
    3) do a quick scan, then recover needed files to new drive

    Ended up costing a few hundred $$, but irreplaceable video is worth it.

    The problem ended up being that they had plugged this Mac formatted drive into a PC to try to access some files, thus corrupting something along the way. Lessons learned:

    1) Don't plug any drive into any computer
    2) Always have backups, because things can go very wrong very fast
     
  7. The SpinDoctor macrumors regular

    Joined:
    Nov 22, 2008
    #7

    I had the same problem and did EXACTLY what you did but I think I discovered the solution to prevent it happening in the future.

    Were you using Windows software called Macdrive? If so, unless you "safely remove" the hard drive, It corrupts.
     
  8. csand thread starter macrumors newbie

    Joined:
    Oct 22, 2009
    #8
    No, the client plugged the drive into his PC to check some things a few weeks ago and I'm assuming he wasn't using anything like Macdrive. I'd never heard of it, but just checked it out - pretty cool. Thanks for the pointers.
     

Share This Page