WD Drive Won't Mount

Discussion in 'OS X El Capitan (10.11)' started by helpimscrewed, May 5, 2016.

  1. helpimscrewed macrumors newbie

    Joined:
    May 5, 2016
    #1
    Please help! My WD drive won't mount but is seen in Disk Utility. It had a name now it is seen as "Untitled" and full when I know there is about 30 gigs free. I ran first aid in Disk Utility and I've attached a screen shot.

    What do I do? If I have to buy recovery software that is fine as long as it works. But if anyone has any suggestions???

    It was working fine earlier today. I ejected as I had to restart my computer but now it won't mount.
     

    Attached Files:

  2. richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
    #2
    I'd recommend that you attempt to recover your data using Data Rescue.
     
  3. helpimscrewed thread starter macrumors newbie

    Joined:
    May 5, 2016
    #3
    Thanks… I’ve tried a couple of data recovery software free trials on the drive (Wondershare & Stella) and it says scanning but gets stuck there… after 3 hours still at 0%. Is that normal or is it because they are free trials? Do you know if I purchase software will I get better results or will it do the same thing?
     
  4. richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
    #4
    I've never used those applications, but I doubt that behaviour is normal (unless the disc is faulty). I wouldn't recommend spending any money unless you're certain you can recover your data.
     
  5. jgelin macrumors 6502a

    jgelin

    Joined:
    Jul 30, 2015
    Location:
    St Petersburg, FL
    #5
    No not normal, they want to prove to you that the software works, not the other way around. So if the software isn't doing the trick it could be dead drive enclosure.
     
  6. helpimscrewed thread starter macrumors newbie

    Joined:
    May 5, 2016
    #6
    Thanks for the responses. I tried another drive enclosure but no luck. It sees the drive as full. Might have to spend $$$ to get it recovered professionally :(
     
  7. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #7
    Some suggestions.
    May help, may not.

    1. Try the drive on A DIFFERENT Mac. Does that change anything?

    2. Try using the recovery app "DataRescue". It's perhaps the best tool on the Mac for data recovery. It's free to download and try.

    You're aware that professional data recovery can be VERY expensive, right? We could be talking into the thousands of dollars here. Take a real deep breath and ask yourself, "would that really be worth it to me?"

    There might be another way to "get the data back" without going to professional recovery. It's risky but IT WORKED FOR ME WHEN NOTHING ELSE WOULD.

    Here's what I did:
    1. I re-initialized the problem drive into a single partition (yes, you're reading correctly, I re-initialized the drive)
    2. IMPORTANT IMPORTANT -- just do a simple quick erase -- DO NOT do a "secure erase". You DO NOT want to "zero out" the data.
    Aside: when you do a quick erase, all you're doing is wiping clean the drive's DIRECTORY. The actual data "out on the platters" is left untouched.
    3. Now, the drive should mount on the desktop, but it will "look empty". It's NOT empty, because the old data is STILL THERE -- only the directory has been replaced.
    4. NOW run your data recovery software on the drive. It should "look around" the directory and "go right to the platters" of the drive. It can now find the data, reconstruct it, and save it to a "scratch drive"
    NOTE: you WILL need to buy ANOTHER drive to serve as your "scratch" drive to receive the recovered files.

    This scheme worked for me when nothing else would, to recover a "lost partition" on which I had a lot of mp3 files...
     
  8. hauntvictim macrumors regular

    hauntvictim

    Joined:
    Sep 23, 2009
    Location:
    Orange County, CA
    #8
    Wow, I may be in the same spot as the OP. Did it work for you?
     

Share This Page