WD Elements won't reformat

Discussion in 'Mac Accessories' started by spellflower, Jan 29, 2012.

  1. spellflower macrumors regular

    Joined:
    Jun 7, 2005
    #1
    I have a WD Elements 1.5 TB External Hard Drive. When I tried to drag and drop files onto it I got a message that said that the disk could not be modified.

    So I tried reformatting it with Disk Utility, Erase.

    I selected Mac OS Extended as the format, and clicked Erase.

    A message came up that said: "Disk Erase failed with the error: File system formatter failed."

    The disk icon disappeared from the desktop.

    I tried again using MS-DOS (FAT), and it worked, and the disk icon returned on the desktop.

    I can now drag files onto the drive.

    Is there a reason I can't use a Mac format? Can I just go ahead and use the MS-DOS (FAT) format? Is it compatible with OSX?
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    You have to format it with the GUID partition type. The MBR partition type can't have a HFS+ partition formatted to it with Disk Utility.
     
  3. spellflower thread starter macrumors regular

    Joined:
    Jun 7, 2005
    #4
    Thank you simsaladimbamba! I followed those steps and it worked.

    May the kindness of strangers shine on you as it has on me.
     
  4. arogge macrumors 65816

    arogge

    Joined:
    Feb 15, 2002
    Location:
    Tatooine
    #5
    Same problem - still not working

    I also have a Western Digital external drive connected through USB, and my situation doesn't fit the usual fixes.

    When I looked at the drive in Disk Utility, there was an existing partition, presumably for Windows because OS X said that the disk was unreadable and wanted me to initialize it. So, I went into the partition manager and tried to create 1 partition, GUID table, and set the size to be the full capacity of the drive. Disk Utility appeared to create the new partition, but then poped up with the error message:

    Partition failed with the error:
    File system formatter failed

    I tried using the Disk Utility option to write zeros to the disk, but I get the error:

    Disk Erase failed with the error:
    Assert: internal error or unimplemented

    Because I can see a volume that represents the partition that I asked Disk Utility to create, I tried formatting that, but I get the error:

    Volume Erase failed with the error:
    File system formatter failed

    I have also tried creating 2 and 4 partitions, and while Disk Utility appears to create the partitions, Disk Utility hangs and spits back:

    Partition failed with the error:
    File system formatter failed

    Each time the popup error appears, the disk disappears from Disk Utility and the USB enclosure has to be powered down and turned on again for the computer to see it, after which I get the error message about the disk being unreadable and demanding to initialize it.

    What would you suggest could be the problem?
     
  5. throAU macrumors 601

    throAU

    Joined:
    Feb 13, 2012
    Location:
    Perth, Western Australia
    #6
    Dead disk.

    I've been unimpressed with WD elements drives lately, mine died within about 3 weeks and i had to RMA it.

    Its a 750 gb drive, and was crapping out around 500gb full. It started doing really weird stuff, like reporting size as 2.1gb before I plugged it into my PC and tried to use it there, and discovered it was all manner of screwed up there too.
     
  6. Victor.Gameiro macrumors newbie

    Joined:
    Dec 31, 2013
    #7
    Failed WD Elements External Drive

    I hace a 1 TB WD Elements HD connected to a MAC mini. Unexpectedly (as expected), when booting up the computer the drive came back with only part of the information. I tried to verify and repair but it did not work. Finally I decided that the information was not that critical and decided to reformat the disk. It worked fine except that now instead of a i TB HD I have a 137 GB HD. What happened. Is this because sectors in the disk are physically damaged or the formatting cannot cover the whole disk. Completely puzzled.

    Thank you for your help.

    Victor
     
  7. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #8
    Did you install the WD software?
     
  8. Victor.Gameiro macrumors newbie

    Joined:
    Dec 31, 2013
    #9
    Crappy WD Drive

    At this stage I am ready to scrap it and never again buy WD drives except that what I think caused the HD to fail also caused the internal MAC HD to fail. At the moment the voting disk is another WD external drive. My plan was to use the failed drive as the BU drive (time machine) and re-install the OSX system software on the internal drive. Now I have to buy another drive to do this. At this time the internal HD is my time machine back up. Any suggestions as to where I should keep it this way or should I re-install the operating system on the internal drive?

    Victor
     

Share This Page