WD External Hard Drive no longer readable

Discussion in 'Mac Accessories' started by ohlund, Mar 19, 2008.

  1. ohlund macrumors newbie

    Joined:
    Dec 2, 2007
    #1
    Sorry if this is in the wrong section.

    I tried searching first, and found a similar thread, but it had no answer.
    -----------------------

    I have a Western Digital 250 GB USB External Hard Drive that no longer seems to work. When I hook the external HD up, I get an error prompt, 'The disc you inserted was not readable by this computer'. The HD icon also does not seem to appear anywhere on my iMac. I have tried using disc utility to repair the drive, as it does recognize that the drive is there, however I get the following error message: "filesystem verify or repair failed."

    I am looking to hopefully salvage my data that's on the external HD, but if it's gone for good, is it possible that I can wipe the drive clean and regain its functionality? Bare in mind that I do not know anything about external HDs, reformatting or anything like that.


    Also, a friend of mine has a copy of Disc Warrior 4, so I possibly have that at my disposal as well (no idea how to use it though).

    Suggestions?
     
  2. cuestakid macrumors 68000

    Joined:
    Jun 14, 2006
    Location:
    San Fran
    #2
    This exact thing happened to me a couple weeks ago-I am sorry to say that I had to do an RMA-I tried several different things including Disk Warrior and nothing worked-whatever data was there is likely gone

    Someone else may be able to give a better solution but for me my drive was dead
     
  3. ohlund thread starter macrumors newbie

    Joined:
    Dec 2, 2007
    #3
    Thanks for the reply, and sorry about your drive. I just used Disk Warrior after reading your post (had no idea if it was the right kind of application) and it actually found a lot of my data.

    This is what it says:

    DiskWarrior has successfully built a new optimized directory for the disk named "Unknown Disc." The new directory is ready to replace the original directory.

    The original directory is damaged and it was necessary to scavenge the directory to find file and folder data.

    Some files that had been lost or thrown away may have been recovered.

    Comparison of the original and replacement directories could not be performed because the original directory was too severely damaged. It is recommended that you preview the replacement directory.


    So, if I click the 'Replace' button, my drive will be functional again?

    As I said, it found a lot of my data, but not all. Should I just 'Replace' the data and cut my losses, or are there any other programs that may be able to recover all my data?

    Thanks!
     
  4. zschiffman macrumors member

    Joined:
    Mar 24, 2008
    Location:
    Norwalk, CT
    #4
    I came across the "unreadable" error message the other day with a LaCie D2. The only option (repair failed) was to reformat using Disk Utility and the drive is working as new (minus the data) :apple:
     

Share This Page