WD external hard drive will not mount anymore

MeValonicAcid

macrumors member
Original poster
Sep 29, 2008
85
13
Belgium
I have a WD external hard drive that will not mount anymore to my iMac (nor Mac Mini).

- It was working fine then just stopped.
- The drive is recognizable in Disk Utility and System Information, connected via FW or USB
- The drive is not visible in Finder
- I just cannot get to the drive content.
- Did a disk repair in Disk Utility: passed
- It is formatted MacOSX Extended (journalled)

Anyone who can help me out... :confused:
(it contains my time machine backup and some manually added backup files and folders)

Regards,

MVa
 

MeValonicAcid

macrumors member
Original poster
Sep 29, 2008
85
13
Belgium
additional info: WD-My Book Studio
- unplugged the drive from USB and power, left it 10 min.
- after 5 min, I heard a 'plop' and verified the power supply died:confused:
(in the wall socket, not plugged in the drive)
- plugged in a backup power supply: disk starts, white front leds stay solid white/on

- disk utility indicates: Mout point: not mounted
- press 'mount disk': message: disk could not be mounted, please try 'First Aid'
- Did execute first aid > verify , repair

...Still not working...:(

Greetzzz,
MVa
 

MeValonicAcid

macrumors member
Original poster
Sep 29, 2008
85
13
Belgium
WD feedback received:
-> sorry for the loss of data,
-> contact a company that provides software for Data recovery to help you out.

I will try to format the drive and use is as 'extra' storage,
definitely not as the main time machine backup location...

additional info: WD-My Book Studio
- unplugged the drive from USB and power, left it 10 min.
- after 5 min, I heard a 'plop' and verified the power supply died:confused:
(in the wall socket, not plugged in the drive)
- plugged in a backup power supply: disk starts, white front leds stay solid white/on

- disk utility indicates: Mout point: not mounted
- press 'mount disk': message: disk could not be mounted, please try 'First Aid'
- Did execute first aid > verify , repair

...Still not working...:(

Greetzzz,
MVa
 

GavUpOnPCs

macrumors newbie
Jan 13, 2014
1
0
External Drive Will Not Mount Anymore

My WD 500G external drive previously mounted fine and recently it would not mount on my new iMAC. First I verified it was still working (played movies on TV fine), then I was surprised when it mounted on my old MAC, "Ok, now were getting somewhere". So the only difference when not working was I connected to a USB hub, so I connect directly to my new iMAC USB connection and VOILA! My drive popped up in FINDER. So lesson learned, USB cables and hubs can intermittently cause problems. A while back my printer would not connect and the problem was my USB cable was too long to make a connection.
I hope this helps some of you folks...:cool:
 

Donfor39

macrumors 68000
Jul 26, 2012
1,630
243
Lanarkshire Scotland
so I connect directly to my new iMAC USB connection and VOILA! My drive popped up in FINDER. :cool:
be

I've yet to fine a powered usb hub for my WD external HD and Epson printer

The the drive works fine when connected direct to airport extreme

The printer is fine via usb hub AND extreme

not sure if its a WD/USB hub compatibilty issue

Wish I could get ALL devices working with a HUB/AES:confused:
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.