WD External HD + Macbook = Boredom

Discussion in 'Mac Accessories' started by weenerdog, Sep 4, 2010.

  1. weenerdog macrumors member

    Joined:
    Dec 4, 2007
    #1
    Hey, was wondering if anyone knows why my 1TB Western Digital External Hard Drive takes a solid 10 minutes or more to mount when connected to my macbook. Every time I connect it to my computer it starts up and I can hear it running but it doesn't show up on my macbook for ages. If anyone else had this problem and knows a fix I would really appreciate it. Cheers. :)
     
  2. CW Jones macrumors 6502

    Joined:
    Nov 24, 2009
    Location:
    CT
    #2
    Not too sure. Something seems wrong, could be the drive. I have a WD 2TB external that takes all of 30-45 seconds to connect. Sometimes a little more however. If you just got the external... I would personally return it and get another one, maybe you just got a bad drive?

    Have you ever had another external plugged in? If yes, what were those results?
     
  3. chrono1081 macrumors 604

    chrono1081

    Joined:
    Jan 26, 2008
    Location:
    Isla Nublar
    #3
    Western digital is famous for making terrible external drives. I had an entire office at my old job filled with between 600 - 800 dead western digital mybooks.


    Drives should mount within 10 seconds. Anything longer the drive is defective.
     
  4. CW Jones macrumors 6502

    Joined:
    Nov 24, 2009
    Location:
    CT
    #4
    I would take a WD over a Seagate ANYDAY. I have seen piles of dead Seagate drives and would never trust one again.
     

Share This Page