WD Green head-park disable: Anybody tried it yet?

Discussion in 'Mac Accessories' started by Makosuke, Apr 9, 2010.

  1. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #1
    So XLR8YourMac had a very interesting tutorial linked today:

    http://www.xlr8yourmac.com/tips/Disable_WDGreen_HeadParking.htm

    ...which basically explains how to disable the automatic head-parking of the WD Green series hard drives.

    I'm very interested in this personally because I'm using one of the new 4K sector WD15EARS drives in a MiniStack on my home server (FW800 to Mac Mini). With this configuration, the WD drive seems to be parking the heads constantly, as in if I'm not writing data to the drive 100% of the time it "nods off" and takes maybe 3 seconds to spin up and come back online when I try to write to it. Which essentially leads to annoying stalls all the time if I'm periodically saving things. It did the same thing with a previous-gen WD Green 750GB, and I've read complaints elsewhere about the same thing, so I don't think it's a problem with the case.

    It's apparently an issue with the WD's own power management, where it tries to save power whenever it can, which both results in stalls and doesn't get along well with the MacOS's own power saving routines (the MacOS can sleep external drives, right?).

    Now, apart from that I absolutely love the drive--it's surprisingly fast, DEAD silent, runs VERY cool, and has a massive 64MB cache. So, I've been hoping for a way to disable this feature.

    And that's what the article above references. I'm going to try it myself once I have the time to pull the drive out of the server and stick it into a PC (no Mac Pro at home for me, so easier to carry it to work), but I wanted to both give a heads up to others and see if maybe someone else had tried this--curious if it worked (or ate your drive or something).

    I'll post when I've tried it and tested the results.
     
  2. Redneck1089 macrumors 65816

    Redneck1089

    Joined:
    Jan 18, 2004
    #2
    What were your results?

    I just cloned my Mac Pro hard drive to a WD green 2TB, 7200 RPM, 64 MB of cache, and I'm constantly getting the clicking sound caused by head parking.
     
  3. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #3
    I really regret having purchased my 2TB EARS drive. Performance was horrible. I have since put the drive in my NAS where I thought I wouldn't notice the horrid performance as much.
     
  4. Redneck1089 macrumors 65816

    Redneck1089

    Joined:
    Jan 18, 2004
    #4
    I followed these instructions, with some slight alterations, and it at least made my hard drive's head from parking so much. So now there's less clicking.

    http://mymacfixes.blogspot.com/2009/06/how-do-i-stop-clicking-noise-from-hard.html

    I was also experiencing slow boot times after installing the cloned drive. I reset the PRAM, and that's made a HUGE difference.

    Performance doesn't seem to be as bad now either. Things seem zippy so far... I'm still getting a bit of head parking (clicking noises) from my drive, but not nearly the amount I was getting beforehand.
     
  5. Transporteur macrumors 68030

    Joined:
    Nov 30, 2008
    Location:
    UK
    #5
    There is a much simpler solution to this. Simply uncheck the box that the system puts the hard discs to sleep in your energy saver preferences.

    Except for the boot drive, I use only Green drives in my Pro (including the mentioned WD20EARS) and I never heard any clicking noise.
     
  6. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #6
    Although the WD firmware tool isn't supposed to be compatible with the EARS series drive, it did recognize it, and I was able to change the auto-sleep period from 4 minutes to disabled.

    However, it turned out to make no difference whatsoever. And, more importantly, it also turns out that it is apparently the NewerTech MiniStack v3 at fault, not the drive itself. I recently installed a Samsung F3 2TB in the same case, and the behavior is identical. I've since read several reports from people using EARS-series drives without that behavior in other setups, from which I've determined that there's something the firmware in the case doesn't get along with at least some drives.

    Early on Newer pointed me at a firmware updater for the bridge board in the case, but that didn't help so I had assumed it was the drive, not the case. My warranty is now expired, and perhaps as a result they've not responded to any more enquiries about the behavior.

    I will at some point try buying another FW800 case to try, which is really disappointing, because I love the form factor, port layout, and adaptive fan control of the MiniStack.

    I don't mean to be insulting, but if it were that simple, I'd never have posted the heads-up in the first place. Do you really think I'd pull the drive, carry it in to work to hook it up to a PC, download and burn a firmware update CD, boot into it, screw with unsupported firmware settings, then take it home and put it back together WITHOUT trying every possible combination of Energy Saver pref pane settings first? I would certainly hope not, and I've had sleep drives disabled from the beginning (though I also tried enabling it for the heck of it--no difference at all).

    In fact, I even tried at one point running a CRON job to touch a file on the drive once every 60 seconds. This resulted in the drive audibly spinning up once every 60 seconds, which pretty much ruled out even the drive firmware as the cause, as that (in WD's utility) identified the sleep interval as longer than 1 minute.


    It's really a shame, because I was up until this point a general fan of NewerTech products--they'd always seemed relatively solid to me.
     
  7. Transporteur macrumors 68030

    Joined:
    Nov 30, 2008
    Location:
    UK
    #7
    I'm sorry, I didn't realise that you run those drives externally. My bad. :(

    Internally, the EARS don't act like you've described it. The drives never spin down and don't make clicking noises.
     

Share This Page