WD My Book Essential Drive not recognized on my Mac

Discussion in 'Mac Accessories' started by Coolmatt49, May 21, 2010.

  1. Coolmatt49 macrumors member

    Jul 10, 2008
    Hey, I'm having problems with my 1 TB WD My Book Essential Drive (External USB HDD). I've only had it for a couple months and now it's not showing up on my Macbook Pro. I checked Disk Utility to see if it shows up there and it doesn't.

    What happens is I plug in my drive to power and the drive starts spinning up. That's all that happens, there's no lights indicating that it is doing something or even on. I then plug it into my Macbook Pro and nothing happens still. My computer doesn't notice the drive and the drive doesn't realize it is connected to a computer. After 30 minutes or so, the drive shows a white light meaning that it is on, but nothing after that. No matter how many times I unplug it/ plug it in or even switch cables, the drive still doesn't want to be recognized. I really don't think the drive is damaged as I've been able to access data on it before and haven't done anything to it that would physically damage the drive since then.

    I did plug in this drive to my Xbox 360 and customized it to be used as an external hard drive, but all my data was retained (I checked after doing it). I don't know if that would have an effect on it, but even then, when I plugged it back into my computer, it would take 30 min or so before my Mac would even mount the drive (it did recognize it as a device though).

    Any help would be appreciated. If you need any additional info, let me know.

    OS: Mac OS X "Snow Leopard" 10.6.2
    Mac: MacBook Pro 2.4 Ghz Early 2008
  2. Mac'nCheese macrumors 68040


    Feb 9, 2010
    I had the same problem with my WD about a year ago. I finally shut down my iMac (it usually justs sleeps) and was prepared to called WD tech support. When I turned everything back on, it was fine. I have no idea why it stopped working or why it started working again. This probably is no help to you whatsover but you know.... I'm a little bored...
  3. Coolmatt49 thread starter macrumors member

    Jul 10, 2008
    I'm starting to dislike WD for that reason. It seems random whenever my drive mounts and whether it works or not. Now, it just doesn't want to work at all no matter what I try.

    I did try shutting my computer down again after you said that while praying that for some cosmic reason my drive would start working again. Unfortunately, it didn't :(. Thanks for your reply though. I might just have to ring up WD tech support in hopes they can help me. My worry is that they will just say they have no clue what it is and that I should send it in.
  4. Coolmatt49 thread starter macrumors member

    Jul 10, 2008
    Anyone have any ideas? I tried plugging it in to my Windows laptop and it still wouldn't recognize it.
  5. jick macrumors newbie

    Mar 9, 2010
    Drivers Wanted


    Apple support and WD support are both worthless here, nowhere I got to find a hint about this, but after timeless hours spent on rebooting, fixing permissions and other useless "tricks", I found out that:

    1 - WD My Book does not work with 10.6 in FireWire 800, only USB connection works

    2- there is a driver needed for 10.6 too, even this driver specs only mentions 10.4 and 10.5 ...
    you can download and install WDDriveManager from:

    It has fixed this issue on both my old MacBook Pro (Intel core 2 Duo) and my MacMini (brand new) connected to 2 different MyBook Models (one Essential 500GB and one Premium 1TB edition) so I guess it's pretty universal I guess.


Share This Page