WD My Book, ownership and file problems

Discussion in 'Buying Tips and Advice' started by pkp, Oct 7, 2007.

  1. pkp macrumors newbie

    Joined:
    Oct 7, 2007
    #1
    Using a Powerbook G4 and the My Book Essential 250GB. Can't get it to work. Says there are "ownership" problems but the only instructions to take care of that problem are for the PC. Going to the Get Info for the drive on a Mac does not give the option to change ownership. It does say that it is set for both read and write. Second, any file with a space, symbol or over about a dozen characters will not copy. Third, if the file has an icon attached to it, it will not copy. And finally, if the drive encounters any of the above, it stops copying anything at that point.
    How do I get this drive to work with my Macintosh files?
    I've tried Retrospect 6.0, Mac backup and simple drag and drop. No go. Can't reformat this drive, it has to be in FAT32. Have gone through the entire WD FAQ section on Mac/Apple plus the troubleshooting and error code sections. Can't find an answer.
    Thanks for any help.
     
  2. dooker777 macrumors member

    Joined:
    Sep 23, 2007
    #2
    Have you tried using disk utility to reformat?
     
  3. pkp thread starter macrumors newbie

    Joined:
    Oct 7, 2007
    #3
    Can't do it. The My Book Essential has to be in FAT32 format which should be cpmpatable with the mac.
     

Share This Page