WD My Book Studio 2nd Ed. 1TB problems.

Discussion in 'Mac Accessories' started by svkrzn, Dec 30, 2009.

  1. svkrzn macrumors regular

    Joined:
    Dec 8, 2009
    #1
    Hello there. Just purchased that drive, but have 2 problems:
    1. The display always shows VIDEOS 09 like a static image. No difference even if the drive has no power and it's not plugged into my MBP. Is it broken or there is a way to activate it?
    2. Tried to install WD Smartware. I open the installer, choose SETUP DRIVE and it asks you to install it in order to continue. I install, now it prompts me for label, protection, registration. Did all the steps, confirmed and pressed CONTINUE. The program hangs and goes back to the previous screen where you have to choose between SETUP or BACKUP. I choose setup again and it asks me to install. Did all the steps over again and now it opens the main program and it hangs each 5 seconds plus changes to label do nothing on the display.
    Broken drive? Should i return it or did i miss something?
     
  2. Jaro65 macrumors 68040

    Jaro65

    Joined:
    Mar 27, 2009
    Location:
    Seattle, WA
    #2
    The display is supposed to work similar to eInk, so yes, it will still be on even when the power is disconnected. It only uses energy as part of the letter change.

    Do make sure that you go on WD website and download the latest firmware. There was a lot of fuss about the s/w functionality with this drive and WD tried to address it.

    I have a couple of 2TB WD Studio drives. I was looking at the drive you have, but didn't get it yet.
     
  3. svkrzn thread starter macrumors regular

    Joined:
    Dec 8, 2009
    #3
    The firmware WD allows me to download is for elite/essential version and when i run the file it says no compatible drive found so i have no idea about how to upgrade it. Also, when i run the installer of smartware, the first screen i see after the installation is where you can change the label, password and registration. I do everything but when i try to register, it says that registration could not complete. Check all the data and try again. But it's all correct, name, surname, email. Have no idea what's wrong.
     

Share This Page