WD My Book suddenly stopped responding

Discussion in 'Mac Accessories' started by theGAPkid, Jul 17, 2008.

  1. theGAPkid macrumors regular

    Joined:
    Sep 13, 2007
    Location:
    UK
    #1
    I have had a Western Digital My Book (Essential Edition) hooked up to my macbook (albeit on and off) for over 5 months. However, I also had a partitioned section solely for my PC. This worked fine for ages. Until the other day, my mac just stopped recognizing it. My windows PC still shows up the "windows" partition formatted FAT32??? if thats correct.

    But the Mac partitioned sectors, formatted as Mac OS Extended (Journaled) are not picked up by my mac any more. Proper strange! It worked flawlessly for ages.

    Thing is, Im reluctant to send it back to play.com (where I purchased it) cos they say they check each item, and technically, it does work, just not on my mac :S

    Help?

    Ta!
     
  2. Cheffy Dave macrumors 68030

    Cheffy Dave

    Joined:
    Feb 5, 2007
    Location:
    Sunny Florida, on the Gulf Coast in Homosassa Fl
    #2
    I have had a Western Digital My Book (Essential Edition):D:D:D
    your first problem!:rolleyes:
     
  3. Wolfgang macrumors member

    Joined:
    Jun 12, 2006
    #3
    I just had this problem and it turned out that my logic board needed to be replaced. Thank goodness for applecare.

    Before reaching this conclusion, however, test your Mac with another firewire drive or another mac booted into target disk mode and see if it comes up. The other possible problem, if you are using USB for your PC and firewire for your Mac, is that the firewire chip inside the hard drive enclosure is dead. So if you can reliably get other firewire drives to mount, it is likely the firewire chip on the drive, but if either others are intermittent or do not mount, it may that you need a logic board replacement.
     

Share This Page