WD My Passport Issue

Discussion in 'Mac Basics and Help' started by 06Honda, Sep 1, 2014.

  1. 06Honda macrumors regular

    Joined:
    May 25, 2011
    #1
    Plugged in my WD My passport today and its not showing up on my Mac like it normally does. The light on the unit is flashing but thats about it. Any ideas how to see my back ups on this and maybe save them elsewhere. All my photos and MacBook Pro backups are on this external drive. Thanks for any info or help.
     
  2. n0cus macrumors 6502

    Joined:
    Jul 16, 2012
    #2
    Open Disk Utility and see if your Mac is detecting it at all.
     
  3. 06Honda thread starter macrumors regular

    Joined:
    May 25, 2011
  4. parestailor macrumors regular

    parestailor

    Joined:
    Mar 15, 2011
    Location:
    London, UK
    #4
    having the same issue

    i have a my passport for mac

    • disk ulility cant see it
    • it wont mount on mac osx 10.9.4 - mini mac my main machine, airbook (or windows 7)
    • tried on windows and mac
    • tried two different usb 3.0 cables
    • mac journalled formatted

    the HD blue light goes on and it sounds like its spinning

    I barely bash this hardrive around, its literally sat in the same spot for months without moving.

    its just all of sudden stopped mounting!

    I REALLY NEED HELP GETTING THE DATA OFF :(
     
  5. kingalexthe1st macrumors 6502

    kingalexthe1st

    Joined:
    Apr 13, 2013
    #5
    I had this problem and solved it by brute force (EDIT: It wasn't this problem. Apologies. It was that my hard drive wouldn't turn off. I can't seem to delete my post though) - switch on the hard drive, and when the blue light flashes, press and hold the power button until it turns off. This will take a while. I didn't count, but it could have been 30 secs (it felt like a minute though). Leave it for a bit (again, I didn't time it, was about the same time it took to turn the thing off) then plug it in to your machine and see if it whirrs to life.

    Note that this was with my WD Passport wireless HD which first stopped being able to connect wirelessly, then just stopped connecting at all. WD seem to know about the problem but don't do much about it; there are a lot of angry folk on their forums.

    Alex
     
  6. parestailor macrumors regular

    parestailor

    Joined:
    Mar 15, 2011
    Location:
    London, UK
    #6
  7. TechpumpkinWD macrumors newbie

    Joined:
    Sep 18, 2014
    #7
    Hello,

    If a My Passport is not showing in Disc Utilities often the reason is something simple. Here are several things try:

    1. Try using a different USB cable, make sure it is as short as the original one, or even shorter. This is important it terns of providing enough power for the drive to function properly.
    2. Try connecting it to different USB ports.
    3. Try connecting it to a different Mac.
    4. Sometimes the drive can misbehave due to insufficient power even if it appears to be spinning when plugged in. To make sure this is not the case you can use a Y-USB cable or connect it through a powered USB hub.
    5. If you have access to a Windows machine test it there with WD Data Lifeguard Diagnostics, you can alos check if it's recognised by Disc Management and what status it's showing http://wdc.custhelp.com/app/answers...2LzIvdGltZS8xNDExMTE4NzkxL3NpZC9od1VKU00ybQ==

    Hope that helps
     

Share This Page