WD My Passport not showing up

Discussion in 'MacBook Pro' started by Arpetee, Mar 13, 2013.

  1. Arpetee macrumors newbie

    Joined:
    Feb 10, 2013
    #1
    Bought a WD My Passport 1TB earlier today. It was the one formatted for Windows, so went home on my desktop and reformatted to exFAT right away. Then loaded files onto it. Then disconnected safely and plugged into my rMBP. Doesn't show up. It does however show up in disc utility. I tried with mac plugged in, all different usb slots, and it was the same cable I used ten minutes prior. Anyone have anything for me? Do I need to download something? Any help is appreciated.
     
  2. pgiguere1 macrumors 68020

    pgiguere1

    Joined:
    May 28, 2009
    Location:
    Montreal, Canada
  3. Arpetee thread starter macrumors newbie

    Joined:
    Feb 10, 2013
    #3
    I'm going to be using it quite frequently on both Windows and OS X. If I can't get it to work I'm just going to take it back and get the Seagate Backup Plus I suppose. I also went into Finder properties and made sure I had external drive checked so already tried that. Any ideas out there?
     

Share This Page