WD My Passport Woes

Discussion in 'Mac Accessories' started by Macca, Jan 28, 2012.

  1. Macca macrumors newbie

    Joined:
    Nov 20, 2010
    #1
    I am having problems with a 1TB WD My Passport USB drive.

    It had been hooked up to my Mac for a few months with no issues, then one day I come home to find the following message displayed:

    "The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off. To eject a disk, select it in the Finder and choose File > Eject. The next time you connect the disk, Mac OS X will attempt to repair any damage to the information on the disk."

    The disk had not been in use or been touched by anyone.

    Now when I connect it the disk spins up and it displays in Finder, but after a few seconds I get the same message and the disk ejects itself. I can't repair it in Disk Utility because it won't stay mounted for long enough to do anything.

    I have tried restarting my Mac with the disk connected and disconnected, I have tried a different cable, I have repaired the permissions on my Mac's main HDD, nothing has worked.

    If I boot into Windows 7 via Bootcamp the disk shows up in Explorer and I can see all the folders and files, but the system seems to have a problem reading the disk beyond that. I have tried to copy the files to another disk in Win7 and have had a very limited success with a few of the files, but the majority of the time the systems hangs and the files are not copied properly. They show on the new disk but are not readable.

    I would like to rescue these files if possible before I try the nuclear option of attempting to format the disk before returning it to WD under the warranty.

    Anybody got any ideas?!

    Thanks.
     
  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    Wirelessly posted (iPhone 4S: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    The drive probably has a bad sector somewhere. If you can remove it from it's case and connect it to an IBM PC, get a copy of Spinrite (www.grc.com) and run that. It's a great HDD maintenance & recovery tool.

    I just used it on Wednesday to repair a voice logging server at work which crashed overnight.
     
  3. Macca thread starter macrumors newbie

    Joined:
    Nov 20, 2010
    #3
    Thanks for the reply. Unfortunately that won't work as the WD My Passport USB3 disks use a proprietary connector that is mounted to the HDD circuit board, so there is no SATA connector to hook the drive up with. You're stuck with using their cable whether the disk is in or out of the case.

    I won't be buying one of these again. 2 out of 2 WD 2.5inch drives have died on me within 6 months of buying them..........
     
  4. rufftackle macrumors newbie

    Joined:
    Feb 16, 2011
    #4
    Yikes! Sorry to hear your having problems. This was exactly my fear with buying a WD HDD when I was debating to buy it or a 2TB Time Capsule... I ended up purchasing the latter, even though it was more than I wanted to spend.

     

Share This Page