WD Mybook for Mac not accesible

Discussion in 'Mac Accessories' started by cabezadelechuza, Mar 31, 2015.

  1. cabezadelechuza macrumors newbie

    Joined:
    Nov 17, 2014
    Location:
    Bridgeport, CT
    #1
    Hello folks!

    My problem started last week when a GENIOUS (yes, me :( ) moved an iMac with an external drive Western Digital Mybook for Mac attached while Final Cut Pro was read/writing on this device. The usb cable was disconnected, I immediately re connected it and there was when the problem started.

    The drive icon disapeared from desktop.
    I restarted the computer and the unlocker requested the password so I thought nothing happened! YEAH!... but right after I enter the pass and hit return the drive gets unlocked and an error message pops saying that the drive needs to be initialized, ignore the error or eject the drive.

    I tried connecting the drive to a windows 7 pc and same thing, I can unlock the drive but seems impossible to read the information.

    So I need your advice, I prefer not to initialize/format the drive since I have a few raw videos that I still need, and before using recovering tools I wanted to know if anyone had a similar situation before.

    Every comment will be much appreciated!

    the exact drive model is:
    Western Digital My Book for Mac 1tb P/N WDBEKS0020HBK-01
    It is connected to an iMac I guess is 2009/2010 and not sure the OSX version but probably Snow Leopard. I also have a late 2010 MacBook Pro with Mountain Lion to try if needed.

    Thank you very much in advance!
     
  2. thedeske macrumors 6502a

    Joined:
    Feb 17, 2013
    #2
    Disk Warrior might repair it, but
    that type of disconnect (during a write) usually means format. Good luck
     
  3. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #3
    If you are unable to repair the drive to again be "mountable" on the desktop, I would suggest this course of action:

    1. First, you will need a data recovery application such as DataRescue, Disk Drill, Stellar Phoenix, etc.

    1a. Before going to step 2, see if the data recovery software can recover the drive first, "as is". It might be able to do this. However, if it cannot, then go to step 2 below.

    2. Once you have data recovery software, re-initialize the drive, BUT:
    IMPORTANT IMPORTANT IMPORTANT
    Do not, repeat, DO NOT choose to "zero out" or "securely erase" the drive. All you want to do is a quick initialization that "leaves the data out there on the sectors" of the platters.

    Once you do this, you will have a drive that mounts on the desktop that looks as if it's "empty" (no files on it), when all you've done is replace the directory and disk drivers, leaving the data untouched.

    3. NOW, launch your data recovery application and "aim it" at the drive. The data recovery app will "skip over" the directory and "go right to the platters", and begin scavenging and re-constructing whatever file info it finds there.

    NOTE: You will need ANOTHER DRIVE to serve as "the scratch drive" onto which the recovered data can be copied.

    4. You should realize that you will probably lose all previous folder hierarchies, and quite possibly lost most file names, as well. This is par for the course with data recovery software, but the consolation is that you get the data itself back.

    I make no guarantees or promises for the above technique, but it worked for me and I was able to use this method to recover many mp3 files from a "lost partition" when nothing else seemed to work.
     
  4. Dr Charter macrumors 6502

    Joined:
    Feb 26, 2011
    Location:
    Oklahoma
    #4
    I'm not saying this will work for you but I had a similar problem with a WD My Book and found a few solutions that seem to work. My drive kept dropping when plugged in. When I plugged it into my Thunderbolt display instead of directly into my MBP, the drive worked. That was an okay solution but I hated losing the USB3 speeds. The other "fix" I tried was using a different USB3 cable. That seemed to work and I have not had any further problems.

    I had tried some of the software and disk repair solutions mentioned above but none worked for me. This is my first WD drive and I've been pretty disappointed overall.
     

Share This Page