WD MyBook FW800 stops working

Discussion in 'Mac Accessories' started by MacUserSince87, Mar 13, 2009.

  1. MacUserSince87 macrumors member

    Joined:
    Aug 18, 2007
    Location:
    Northern Virginia, USA
    #1
    I have a WD 1TB FW800 MyBook I use with TimeMachine for backing up my iMac 24" running 10.5.6. The drive supports FW800, FW400, and USB

    Time machine stopped working about 10 days ago and I found the problem was that the MyBook wasn't mounting. I had firmware related issues when I first bought it so the first thing I did was check the WD site for new firmware and installed it and the new version of WD utility via a USB connection. FW still didn't work.

    I've contracted WD support, which suggested a Windows only diagnostic program. I don't have a Windoz machine with a compatible FW port so I ran some other tests here's what I found:

    USB: Mounts Works OK when plugged into USB port.

    FW800 Direct from iMac: From power off state does not turn on or connect when FW800 cable connected. When powered on manually indicator light glows steady (no sign of communication with computer)


    FW400 Direct from iMac: From power off state will turn on when FW400 cable connected, but does not mount and powers down after about 30 sec.

    FW400 Daisy Chain: I also have a Maxtor FW400 drive which works normally on the FW400 port. When I plug the WD MyBook into its 2nd FW400 port it mounts normally on the desktop.

    2nd Computer G4 Power PC OSX 10.3.9

    FW400: The MyBook mounts normally when plugged into the FW400 port

    Unfortunately I don't have any other FW800 devices I can use to test the port on the computer.

    There's apparently a known issue with FW drives and TimeMachine, but my worked fine for the past year with the FW800 connection. So the issue appears to be some new incompatibility with a direct connection to FW ports on the iMac which started occurring about 11 days ago. That's when Time Machine stopped working on the FW800 connection.

    I do system upgrades when prompted. Is there a chance one done about 12-13 days ago which caused the problem?
     
  2. puma8100 macrumors newbie

    Joined:
    Oct 17, 2007
    #2
    same problem with mine.

    I had the same problem with my wd my book studio edition last week. Just wouldn't mount. It only would mount again until I mounted it on another iMac.

    Besides that it overhearts a lot and freezes.
     
  3. LeeTom macrumors 68000

    LeeTom

    Joined:
    May 31, 2004
    #3
    is "overhearting" what emo kids do?
     
  4. robanga macrumors 68000

    robanga

    Joined:
    Aug 25, 2007
    Location:
    Oregon
    #4
    I had the same issue with a WD drive last year. It would stop working on FW. You may want to check WD's support site, because I vaguely remember hearing about a firmware upgrade. I ultimately returned mine.
     
  5. MacUserSince87 thread starter macrumors member

    Joined:
    Aug 18, 2007
    Location:
    Northern Virginia, USA
    #5
    Problem Solved:

    I solved the FW 800 mounting problem by resetting the SMC on my iMac 24" per the instructions in this Apple tech note:

    http://support.apple.com/kb/HT1543?viewlocale=en_US

    Shut down
    Unplug everything including the power cord
    Wait 15 sec.
    Replug Power
    Reinsert cables
    Power up

    FW800 functional again...
     

Share This Page