WD MyBook Home Firewire problems

Discussion in 'Mac Accessories' started by Borj2K, Dec 31, 2009.

  1. Borj2K macrumors newbie

    Joined:
    Sep 30, 2008
    #1
    I have searched these forums and many others for a solution but have not found anything that helps. I have a 1tb WD MyBook that will not mount on my iMac through firewire, but works with usb. I have tried connecting it to my macbook with firewire, and it works. Also works on another iMac I tried, just not on mine. That led me to believe the ports were bad on my iMac. I tested a few other firewire devices, and they all worked. So the drive is in working condition, and so are the ports on the mac. I have tried resetting the pram, turning off and unplugging all components and letting it sit for 25-30 mins, repairing disks, different firewire cables, even tried a firewire 400 to 800 adapter. Nothing works.
    Then, I decided to try something different. Seeing as there are two FW ports on the back of the drive, I ran one cable to my iMac, and another cable to my macbook. Finally, the drive shows up on my iMac. Once I got it working, I unplugged the cable from the drive to my macbook, and it locked up the drive. I can't read/write onto it. But when I plug the cable from the drive back into the macbook, it works again.
    Why do I need it connecting to two different computers to get it to show up on my iMac? Is it a power issue? Before, it just said 'Unknown device' in System Profiler. When it's connected, it shows both macbook and mybook.
    As I said, I've looked everywhere for an answer but I don't know why it's doing this. Any help is appreciated.
     
  2. Borj2K thread starter macrumors newbie

    Joined:
    Sep 30, 2008
  3. Jaro65 macrumors 68040

    Jaro65

    Joined:
    Mar 27, 2009
    Location:
    Seattle, WA
    #3
    You really should not need it connecting to two computers in order for the drive to mount. Have you tried going to the WD site and see if there is some support documentation to help you troubleshoot it? I have two WD My Studio drives connected in a FireWire chain and they have been working just fine.
     
  4. Borj2K thread starter macrumors newbie

    Joined:
    Sep 30, 2008
    #4
    I've looked through everything on the support site. Downloaded all the drivers and software as well. As I said, the drives work fine when connected to other macs, just not this one.
     

Share This Page