WD MyPassport Sleep Issue

Discussion in 'Mac Accessories' started by drmarty, Feb 9, 2014.

  1. drmarty macrumors newbie

    Joined:
    Feb 9, 2014
    #1
    I'm using a 1TB WD My Passport Ultra for my Time Machine Backup drive. I'm working on a MBP running Mavericks.

    Noting that every time the MBP sleeps it also puts the WD drive into sleep mode and "ejects" it. I get the warning that the drive was not ejected properly. The icon for the drive disappears from the desktop and Time Machine cannot see it. The drive is also not listed when I open finder after this happens. My only solution has been to unplug the USB cable and then plug it back in, at which point the drive is recognized and Time Machine will work.

    I went into the WD application manager and changed the sleep setting to "never" but it did not stay in that mode. There is a warning that the OS my override this.

    How do I set up the WD drive to work with OSX not to shut down and eject the disc?
     
  2. xraydoc macrumors 604

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #2
    Try turning off disk sleep in the energy control panel.
     
  3. drmarty thread starter macrumors newbie

    Joined:
    Feb 9, 2014
    #3
    Sleep issue

    Unfortunately turning off the disc sleep in energy control paneldid not solve the issue:( It still gave me the same error that the disc was not ejected properly.
     
  4. djc6 macrumors 6502

    Joined:
    Aug 11, 2007
    Location:
    Cleveland, OH
    #4
    I am having the same problem with my father's USB 3.0 2TB Seagate Expansion Desktop Hard Drive.

    I noticed it happens on his Late 2013 iMac but not on my Mid-2012 15" MacBook Pro Retina. Both are running Mavericks.

    ----------

    There is a pretty popular Mtn. Lion thread about this issue, with no resolution:

    https://discussions.apple.com/thread/5306476?start=0&tstart=0
     
  5. angelino macrumors newbie

    Joined:
    Jan 5, 2013
    #5
    Having the same troubles.. particularly irritating when working on a project, taking a break, and having to remount all the drives to continue.

    Any leads into fixes for this?
     
  6. matreya macrumors 65816

    matreya

    Joined:
    Nov 14, 2009
    #6
    I find that not sleeping my Mac avoids any drives unmounting unceremoniously...
     
  7. begonia97 macrumors newbie

    Joined:
    Mar 26, 2015
    #7
    Solved!

    After much trial & error, I finally have this widely reported problem fixed!

    Like others, my WD My Passport for Mac drive would fail to wake up from sleep. Frequently this was corrupting the Time Machine backup file, causing me to lose my entire history (thankfully this was not the only copy) and backup the entire system from scratch repeatedly. This issue seemed to be confined to the WD drive - the Seagate drive I use as a mirror had none of these problems. This problem first developed when I upgraded to Yosemite -- all my drives worked perfectly under Mavericks.

    First, I set the sleep timer to "Never" in the WD Drive Utilities app. And I also unchecked the "Put hard drives to sleep when possible" option in System Preferences - Energy Saver. These seemed to be obvious choices, but had no impact in solving the problem. However, they may be part of the solution, so I'd be hesitant not to follow these steps.

    The key to stopping the problem turned out to be selecting "Prevent computer from sleeping automatically when the display is off" also under System Preferences - Energy Saver. Basically, prevent your Mac from going to sleep and the WD drive never unmounts. Not the most energy efficient solution, but you can still have the display go to sleep & I figure that is the largest energy hog. It came down to a choice of losing a few pennies of juice vs. having corrupted backups.

    I made this change about a week ago and have been enjoying flawless backups ever since.
     

Share This Page