WD Passport Essential not mounting

Discussion in 'Mac Accessories' started by StijnHemel, Aug 14, 2014.

  1. StijnHemel macrumors newbie

    Joined:
    Aug 14, 2014
    #1
    After reading hundreds of threads on WD Passport Essential problems I haven't found a solution yet so I hope someone here can.

    I have partitioned the drive in to 2 sections, one of 400gb for Time Machine and one of 100gb for other usage.
    After this I encrypted it with the WD software (I wish I had known this would give problems).
    This set-up worked for me for a few years but all of a sudden it stopped functioning properly.

    So this is what I've tried:
    1. Connect the drive
    2. open the unlocker and put in the password
    3. Unlocker accepts the password and the virtual drive unmounts itself (as normal)
    4. Disk utility doesn't recognise a drive nor does system profiler.
    5. The time machine partition shows up but I can't go any further than the first map and that one is 0 kb although the partition shows 300gb being used.


    After filling in the password the partitions show up for a few seconds in disk utility grayed out and I can't click on it.
    System profiler does recognise the drive until I put in the password.

    As the drive contains my back-ups I'm desperate to get the files on it back.
    Thank you to anyone who tries to help!

    [​IMG]
    [​IMG]
    [​IMG]
     
  2. eduardrw, Aug 15, 2014
    Last edited: Aug 15, 2014

    eduardrw macrumors 6502

    Joined:
    May 20, 2013
    #2
    Try to uninstall the WD software and the reinstall it.

    Otherwise I suggest to boot into your recovery partition. From there go to Disk Utility and run a repair disk. See if that helps.

    For the future: I have uninstalled WD software and run without it as a normal disk. For encryption I use either Time machine or I create an encrypted disk image on the disk and then mount it.
    http://support.apple.com/kb/ht1578

    Oh - and as always : one backup is no backup! have at least 3 backups on two different medias and in two locations!
     

Share This Page