WD Passport not working properly

Discussion in 'Mac Accessories' started by dogtonharrants, Sep 23, 2013.

  1. dogtonharrants, Sep 23, 2013
    Last edited: Sep 23, 2013

    dogtonharrants macrumors newbie

    Joined:
    Jan 6, 2008
    #1
    Hello,

    My WD Passport, which up to now has been working fine when plugged into my iMac has stopped showing up in the finder.

    In Disk Utilities, it is shown as a connected drive but, unlike my iMac's hard drive, the number of files comes up as zero.

    When the WD Passport is plugged into the iMac (USB), the hard drive can be heard whiring round and the blue light is on.

    I have tried swapping USB cables and plugging the drive into 2 other Macs, but the same thing happens. I have also tried to 'repair' and 'verify' the drive within Disk Utilities but get non-informative errors.
    Any suggestions of how I can access my files please?

    Many thanks
     
  2. thedeske macrumors 6502a

    Joined:
    Feb 17, 2013
    #2
    Repair permissions on your imac startup drive and restart with the WD plugged in. Sounds like you have the basics covered. Good luck
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California

Share This Page