Resolved Weak wifi/GPS signal on iPhone 3GS

umiwangu

macrumors 6502
Original poster
Sep 4, 2006
478
0
Malawi
I bought a 16 GB iPhone 3GS (5.1.1) off of Craigslist, and afterwards, I realized it has very weak wifi reception and apparently can't get any GPS signal. Where my other iPhones (2x 3GS) often get 2-3/3 wifi bars, this one can't pick up anything. Standing outside in the open sky, the Maps app spends more than a minute trying to get a fix, and eventually it gave up.

When I bought it, it had the iPad baseband on it, so I used Redsn0w to downgrade it to 05.13.04 and then unlocked it with Ultrasn0w.

The 3, 4, & 5 serial numbers are 025, so the iPad firmware bricking issue isn't the problem.

I searched a bit online and it seems like it's a known issue, but I haven't found any solutions yet. https://discussions.apple.com/thread/2724930?start=45&tstart=0

Any ideas?
 
Last edited:

luisadastwin

macrumors regular
Many people claim that the newer iOS stop the GPS from working any further in 3GS iPhones, mainly due to the BASEBAND version.

So, I also tried to downgrade BASEBAND to an older version (05.13.04) using redsn0w in the latest version available (Version 0.9.15b3).

I am also trying to check all the thing I have to do to make it work...

You might want to check my story on this:

http://forums.macrumors.com/showthread.php?t=1498532
 

umiwangu

macrumors 6502
Original poster
Sep 4, 2006
478
0
Malawi
Many people claim that the newer iOS stop the GPS from working any further in 3GS iPhones, mainly due to the BASEBAND version.

So, I also tried to downgrade BASEBAND to an older version (05.13.04) using redsn0w in the latest version available (Version 0.9.15b3).

I am also trying to check all the thing I have to do to make it work...

You might want to check my story on this:

http://forums.macrumors.com/showthread.php?t=1498532
Hi Luis, thanks for the reply.

I know that using the iPad baseband can cause certain versions of the 3GS to stop working, but it wasn't the case with this problem.

I actually got it fixed a couple weeks ago. I went ahead and ordered a new wifi/gps antenna from eBay for a couple bucks and replaced it. After that, wifi and gps were working as normal.

Perhaps this is your issue as well?

Seth