Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

ninethirty

macrumors 68000
Original poster
Mar 1, 2006
1,541
1,616
I know that 10.0.2 was supposed to fix this, but it hasn't. My conditions and temperature complications don't display anything. I've checked cellular connection, it's fine, wifi is fine, location services, fine, I've set the default location. This is kind of driving me nuts. Anyone know how to fix this?
 

KnownSyntax

macrumors member
Mar 23, 2022
37
17
Phoenix, AZ
Ironically after restoring my Ultra 1 after getting a new iPhone, my weather-related complications aren’t working either even after following Apple’s own guidelines on resetting location, and privacy settings.

Hopefully 10.1 fixes this, since it seems to be more widespread than just the Ultra 2.
 

torkles

macrumors newbie
Oct 5, 2023
6
4
following apple's instructions resolved my issue:


option 2 there, resetting the phone's location&privacy fixed it for me. after i restarted the phone and the watch and opened the weather app i was prompted to allow location services and then it was good.
 
  • Like
Reactions: Hakiroto and 3Rock

minicard

macrumors regular
Oct 31, 2014
241
86
Oregon
I have Ultra 1 and I have only 10.0.1 available. My weather complication stopped working after that upgrade. However with the latest ios17.0.3 update yesrterday, it’s back working now.
 

MarkNewton2023

macrumors 6502a
Sep 17, 2023
604
602
I know that 10.0.2 was supposed to fix this, but it hasn't. My conditions and temperature complications don't display anything. I've checked cellular connection, it's fine, wifi is fine, location services, fine, I've set the default location. This is kind of driving me nuts. Anyone know how to fix this?
That is interesting 🧐 🤔 mine is working fine after the update. You may need to consult with Apple Support or Genius Bar personnel. They should be able to help you as they are the Subject Matter Expert on all Apple products.
 

matrix07

macrumors G3
Jun 24, 2010
8,226
4,893
Strangely enough rain complication on watchOS 9 (and iOS 16) had never worked for me but works perfectly on watchOS 10 and iOS 17.
 

3Rock

macrumors 6502a
Aug 25, 2021
612
646
following apple's instructions resolved my issue:


option 2 there, resetting the phone's location&privacy fixed it for me. after i restarted the phone and the watch and opened the weather app i was prompted to allow location services and then it was good.
Method number one worked for me until 24 hours later then the weather app did not show up on my watch. Had to do it all over again. let’s see if it works this time permanently.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.