Web Browser opens on 2nd screen

Discussion in 'Mac Basics and Help' started by RaceJunkie, Jul 1, 2008.

  1. RaceJunkie macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #1
    All of a sudden every time I start up Firefox it will open on my 2nd monitor, any fix for this?
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    tried dragging it to your primary screen, quitting it, then opening again?
     
  3. RaceJunkie thread starter macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #3
    yea tried that one already, thanks.
     
  4. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #4
    try deleting org.mozilla.firefox.plist in your home Library's preferences folder. this will reset the window sizes and positions and the settings in Firefox's preferences.
     
  5. patrickmacrumor macrumors regular

    Joined:
    Jun 24, 2008
    #5
    Do you have spaces enabled ? In spaces, you can specify where you want an application to open. Just another suggestion to try.

    --
    Patrick
     
  6. RaceJunkie thread starter macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #6
    Thanks but did not work.
    I do have spaces enabled, where do I edit this feature that makes Firefox open on the left where my extra monitor is?
     
  7. patrickmacrumor macrumors regular

    Joined:
    Jun 24, 2008
    #7
    In system preferences->Exposé&Spaces.
     
  8. RaceJunkie thread starter macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #8
    Yea but is there a option there someplace to, make FF open on let or main monitor? I really didn't see anything of that sort.
     
  9. patrickmacrumor macrumors regular

    Joined:
    Jun 24, 2008
    #9
    Do you see Application Assignments? If yes, click on the + sign and add the desired application.
     
  10. RaceJunkie thread starter macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #10
    Yes I did this but still opens on left, very weird.
     
  11. patrickmacrumor macrumors regular

    Joined:
    Jun 24, 2008
    #11
    I'll try it this afternoon when I get home. I don't have Spaces enabled since I have two monitors, and they are enough for me.

    --
    Patrick
     
  12. RaceJunkie thread starter macrumors regular

    Joined:
    Dec 18, 2007
    Location:
    North Carolina
    #12

    Thanks for your help.
     
  13. RaceTripper macrumors 68030

    Joined:
    May 29, 2007
    #13
    Try disconnecting your second monitor. Then launch and quit the browser. Then reconnect the second monitor.
     
  14. patrickmacrumor macrumors regular

    Joined:
    Jun 24, 2008
    #14
    Yes, try this solution. I though Spaces would allow you to choose the secondary display, but I was wrong. I just enabled Spaces, and it allows me to pick a space only.

    Now, I've also notice that if you disconnect the secondary monitor, it usually has to bring everything to the primary/single monitor. Connecting the monitor back while the computer is still one can screw things up. Try starting the computer with the secondary monitor first, shutdown, connect the secondary monitor, and start the computer again.

    --
    Patrick
     
  15. FtRapture macrumors newbie

    Joined:
    Sep 9, 2008
    #15
    I know this be old news but in case no one has answered yet.





    Hi, what seems to work is open Firefox drag it over to your main monitor (DO NOT MAXIMIZE FIREFOX) then close the windowed Firefox and now on reload it should open in your main screen.
     
  16. Pedro Blanco macrumors newbie

    Joined:
    Jul 30, 2008
    #16
    Browser opens on second monitor

    Hi, did anyone solve this mystery, I have tried all the above to no avail, any help would be really appreciated.

    Thanks

    Pedro
     
  17. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley

Share This Page