Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

cyberghoser1

macrumors member
Original poster
Nov 18, 2009
98
0
Athens, Hellas
Hello all, lately using my powerbook g4, I discovered that javascript under Safari 5.0.6 which is latest version of it for 10.5.8, is making browsing terribly slow, especially in google search.

When it comes to load images on google's search i have the spinning beach ball problem, meaning page loading with all those images it taking ages, if i disable javascript everything is working great, but some pages need it.

I came across Javascript Blocker extension but it will not work with this safari version, I tried a lot of other browsers, but not one does the job as safari, i mean TenFourFox, Camino, Omniweb etc are good but not so great as safari when it comes to scrolling etc.. Only Firefox 3.6.28 seems to do the job at least

What i need is a hint or something to disable javascript only in google and/or any other webpages i visit, something like Javascript blocker but for that version of safari, i could not find something related, maybe i didnt search enough but if someone knows, you are more than welcome to help :)
 
Last edited:

Lil Chillbil

macrumors 65816
Jan 30, 2012
1,322
96
California
Hello all, lately using my powerbook g4, I discovered that javascript under Safari 5.0.6 which is latest version of it for 10.5.8, is making browsing terribly slow, especially in google search.

When it comes to load images on google's search i have the spinning beach ball problem, meaning page loading with all those images it taking ages, if i disable javascript everything is working great, but some pages need it.

I came across Javascript Blocker extension but it will not work with this safari version, I tried a lot of other browsers, but not one does the job as safari, i mean TenFourFox, Camino, Omniweb etc are good but not so great as safari when it comes to scrolling etc.. Only Firefox 3.6.28 seems to do the job at least

What i need is a hint or something to disable javascript only in google and/or any other webpages i visit, something like Javascript blocker but for that version of safari, i could not find something related, maybe i didnt search enough but if someone knows, you are more than welcome to help :)

Have you tried stainless for a browser option
 
Comment

rjcalifornia

macrumors 6502a
Oct 4, 2012
668
5
El Salvador
Hello all, lately using my powerbook g4, I discovered that javascript under Safari 5.0.6 which is latest version of it for 10.5.8, is making browsing terribly slow, especially in google search.

When it comes to load images on google's search i have the spinning beach ball problem, meaning page loading with all those images it taking ages, if i disable javascript everything is working great, but some pages need it.

I came across Javascript Blocker extension but it will not work with this safari version, I tried a lot of other browsers, but not one does the job as safari, i mean TenFourFox, Camino, Omniweb etc are good but not so great as safari when it comes to scrolling etc.. Only Firefox 3.6.28 seems to do the job at least

What i need is a hint or something to disable javascript only in google and/or any other webpages i visit, something like Javascript blocker but for that version of safari, i could not find something related, maybe i didnt search enough but if someone knows, you are more than welcome to help :)

That's hard to believe, Safari doesn't give problems with Google or any other pages...
 
Comment

Wildy

macrumors 6502
Jan 25, 2011
323
0
Safari > Preferences > Advanced > Show Develop menu in menu bar. Then Safari > Preferences > Security > No JavaScript. JavaScript will be disabled by default, if you need it for a specific page then you can quickly enable it by clicking on Safari > Develop > Enable JavaScript.

Alternatively you can install GlimmerBlocker which will work in the background to block ads across all HTTP traffic (regardless of browser). You can add in some custom rules to block all JavaScript except those on the pages you whitelist.

I second using Stainless. It is nowhere near as feature-rich as Safari, but it is sure as hell a lot lighter and pretty snappy for the most part.

Hope that helps.
 
Comment

cyberghoser1

macrumors member
Original poster
Nov 18, 2009
98
0
Athens, Hellas
Have you tried stainless for a browser option

Thanks I will try it.

That's hard to believe, Safari doesn't give problems with Google or any other pages...

Believe me it does, otherwise I don't see why I should post this...I will eventually make a screen record so you can see it.

Safari > Preferences > Advanced > Show Develop menu in menu bar. Then Safari > Preferences > Security > No JavaScript. JavaScript will be disabled by default, if you need it for a specific page then you can quickly enable it by clicking on Safari > Develop > Enable JavaScript.

Alternatively you can install GlimmerBlocker which will work in the background to block ads across all HTTP traffic (regardless of browser). You can add in some custom rules to block all JavaScript except those on the pages you whitelist.

I second using Stainless. It is nowhere near as feature-rich as Safari, but it is sure as hell a lot lighter and pretty snappy for the most part.

Hope that helps.

Thanks a lot I will look into that, I know the trick with the developer menu, however I prefer something like GlimmerBlocker you said, so I dont have to interact with it each time.
 
Comment

chibiterasu

macrumors 6502
Apr 5, 2012
337
24
London, The United Kingdom
If your having problems with google on safari then I'm also going to give a shout to leopard WebKit seeing seeing as your on 10.5.8. I use it as my main browser on the iMac G4, stainless is also good but I'm a sucker for the features and the way safari looks. I hope that's of some help.
 
Comment

cyberghoser1

macrumors member
Original poster
Nov 18, 2009
98
0
Athens, Hellas
If your having problems with google on safari then I'm also going to give a shout to leopard WebKit seeing seeing as your on 10.5.8. I use it as my main browser on the iMac G4, stainless is also good but I'm a sucker for the features and the way safari looks. I hope that's of some help.

stainless is good, but lack of features, i will try Webkit now to see if it doeas better, the thing is that only under safari i have this problem, all other browsers act correctly with google images
 
Comment

chibiterasu

macrumors 6502
Apr 5, 2012
337
24
London, The United Kingdom
stainless is good, but lack of features, i will try Webkit now to see if it doeas better, the thing is that only under safari i have this problem, all other browsers act correctly with google images

Ah you mean the whole continus page of images insted of clicking to the next page at the bottom. Then yes leopard webkit (http://code.google.com/p/leopard-webkit/) should show the continuos page of images, at least it does on my iMac G4.
 
Comment

cyberghoser1

macrumors member
Original poster
Nov 18, 2009
98
0
Athens, Hellas
Ah you mean the whole continus page of images insted of clicking to the next page at the bottom. Then yes leopard webkit (http://code.google.com/p/leopard-webkit/) should show the continuos page of images, at least it does on my iMac G4.

Too bad, it doesnt do it better, same result, when i launch webkit, it opens as Safari 5.0.6, same think with images on google, i guess its a no-go.
 
Comment

chibiterasu

macrumors 6502
Apr 5, 2012
337
24
London, The United Kingdom
Too bad, it doesnt do it better, same result, when i launch webkit, it opens as Safari 5.0.6, same think with images on google, i guess its a no-go.

Really, what is your result with google images? did you click on the right safari icon?? (the golden compass)

Edit: Picture from iMac G4 which shows google images with continous pages and pictures that use all available space in the browser window.
 

Attachments

  • Picture 1.jpg
    Picture 1.jpg
    345.4 KB · Views: 266
Last edited:
Comment

B-G

macrumors regular
Dec 14, 2011
179
20
As already suggested Leopard-Webkit and Glimmer Blocker should improve things a lot. Leopard-Webkit will indeed launch Safari 5.0.6 , but it will use a much updated, faster and more secure version of Webkit. It will be even faster if you enable the advanced features using the shell script that comes with L-W dmg file.
To block javascript from a site in Glimmer Blocker, if I remember correctly you will have to create a new rule and add the string gb.zapScriptElements(); in the transform tab.

There used to be a Safari extension called Javascript Blacklist, useful to block javascript from a whole domain. It seems to have disappeared after MobileMe went down.

One thing I _strongly_ suggest to do is disabling preview images in chronology and Top Sites. It may seem a small detail, but it made a ton of difference on my old eMac. I used TinkerTool to do this (remember to reset Safari afterwards). Safari won't stress the system anymore to save these images on your HD, and this should result in less spinning wheels.
 
Comment

cyberghoser1

macrumors member
Original poster
Nov 18, 2009
98
0
Athens, Hellas
Really, what is your result with google images? did you click on the right safari icon?? (the golden compass)

Edit: Picture from iMac G4 which shows google images with continous pages and pictures that use all available space in the browser window.

I mean, when you are in google central page and search for example: ibook g4, the serach results appear fast, but takes time to load the images result, and if i switch to the images only results all pictures are grayed out, and the mouse becomes like beach, you know spinning thing and i hate to force close safari or wait a lot of time for it to show images, only happens in google though. Even with Webkit its the same result.

As already suggested Leopard-Webkit and Glimmer Blocker should improve things a lot. Leopard-Webkit will indeed launch Safari 5.0.6 , but it will use a much updated, faster and more secure version of Webkit. It will be even faster if you enable the advanced features using the shell script that comes with L-W dmg file.
To block javascript from a site in Glimmer Blocker, if I remember correctly you will have to create a new rule and add the string gb.zapScriptElements(); in the transform tab.

There used to be a Safari extension called Javascript Blacklist, useful to block javascript from a whole domain. It seems to have disappeared after MobileMe went down.

One thing I _strongly_ suggest to do is disabling preview images in chronology and Top Sites. It may seem a small detail, but it made a ton of difference on my old eMac. I used TinkerTool to do this (remember to reset Safari afterwards). Safari won't stress the system anymore to save these images on your HD, and this should result in less spinning wheels.

Im downloading the latest stable as i can see in Webkit's website, do i need to download also the patches?
 
Comment

B-G

macrumors regular
Dec 14, 2011
179
20
When you open L-W .dmg file (for example the latest 536.28.8) you can see a shell script named "enable advanced features". Just double click on it.
By the way, this is the content of that script, it should give you an idea of what it is doing:

#!/bin/bash

defaults write com.apple.Safari WebKitFullScreenEnabled -bool YES
defaults write com.apple.Safari WebKitAcceleratedCompositingEnabled -bool YES
defaults write com.apple.Safari WebKitAccelerated2dCanvasEnabled -bool YES
defaults write com.apple.Safari WebKitAcceleratedDrawingEnabled -bool YES
defaults write com.apple.Safari WebKitCanvasUsesAcceleratedDrawing -bool YES
defaults write com.apple.Safari WebKitWebGLEnabled -bool YES
defaults write com.apple.Safari WebKitWebAudioEnabled -bool YES


Even if it doesn't solve the issues you are having with Google Images, it will make using L-W more enjoyable. :)
 
Comment

cyberghoser1

macrumors member
Original poster
Nov 18, 2009
98
0
Athens, Hellas
When you open L-W .dmg file (for example the latest 536.28.8) you can see a shell script named "enable advanced features". Just double click on it.
By the way, this is the content of that script, it should give you an idea of what it is doing:

#!/bin/bash

defaults write com.apple.Safari WebKitFullScreenEnabled -bool YES
defaults write com.apple.Safari WebKitAcceleratedCompositingEnabled -bool YES
defaults write com.apple.Safari WebKitAccelerated2dCanvasEnabled -bool YES
defaults write com.apple.Safari WebKitAcceleratedDrawingEnabled -bool YES
defaults write com.apple.Safari WebKitCanvasUsesAcceleratedDrawing -bool YES
defaults write com.apple.Safari WebKitWebGLEnabled -bool YES
defaults write com.apple.Safari WebKitWebAudioEnabled -bool YES


Even if it doesn't solve the issues you are having with Google Images, it will make using L-W more enjoyable. :)

Thanks for your help, i installed it, run the script to enable advanced features, but google is still a no go, on the first search, results are fast but the three images that will open on top wil result in a wheel spinning, and if i ever click on pictures results, it will spin a lot, and i have to force close, i dont understand why.
 
Comment

B-G

macrumors regular
Dec 14, 2011
179
20
I don't know what to say. My eMac is a lot less powerful than your PowerBook, but Google Images is working well for me.
What happens if you reset Safari, or if you disable javascript and plugins?
Did you try disabling preview images?
May I ask you what extensions are you using? Some of them can be quite heavy. When I tried Adblock, for example, it gave so many spinning wheels that I uninstalled it after five minutes (that's why I'm using GlimmerBlocker now).
 
Comment

cyberghoser1

macrumors member
Original poster
Nov 18, 2009
98
0
Athens, Hellas
I don't know what to say. My eMac is a lot less powerful than your PowerBook, but Google Images is working well for me.
What happens if you reset Safari, or if you disable javascript and plugins?
Did you try disabling preview images?
May I ask you what extensions are you using? Some of them can be quite heavy. When I tried Adblock, for example, it gave so many spinning wheels that I uninstalled it after five minutes (that's why I'm using GlimmerBlocker now).

Im only using clicktoflash and adblock, i know its really strange, i already reset safari twice, without any luck, when i disable javascript its working great but some websites like facebook etc need it, really weird. Where do i disable preview images in webkit/safari?

Edit: You where right, adblock was causing the issue!!!
 
Comment

B-G

macrumors regular
Dec 14, 2011
179
20
Glad you find the culprit! AdBlock is really heavy. it gave me problems even on my mid-2009 MacBookPro. GlimmerBlocker is a lot lighter and much more powerful.

Using TinkerTool is the easiest way to disable preview images in Safari. It's one of the options in the Safari tab.

Also, big stroke of luck!
I found a copy of Javascript Blacklist 1.0.1 in a remote recess of my hard disk. I'm going to attach it to this post.
I don't remember when or why I saved it. I must have been developing premonition powers... :eek:
 

Attachments

  • JavaScript-Blacklist.safariextz.zip
    28.8 KB · Views: 78
Last edited:
Comment

cyberghoser1

macrumors member
Original poster
Nov 18, 2009
98
0
Athens, Hellas
Glad you find the culprit! AdBlock is really heavy. it gave me problems even on my mid-2009 MacBookPro. GlimmerBlocker is a lot lighter and much more powerful.

Using TinkerTool is the easiest way to disable preview images in Safari. It's one of the options in the Safari tab.

Also, big stroke of luck!
I found a copy of Javascript Blacklist 1.0.1 in a remote recess of my hard disk. I'm going to attach it to this post.
I don't remember when or why I saved it. I must have been developing premonition powers... :eek:

Thank you a lot! Actually i installed GlimmerBlocker but i still see facebook ads, good you found Javascript Blacklist, this will help a lot too!
 
Comment

B-G

macrumors regular
Dec 14, 2011
179
20
You're welcome!
Right off the box GlimmerBlocker tends to block less ads than adblock. This is not to hamper sites functionality by blocking too much. Fortunately creating personal filters and rules is simple (while not as easy as in adblock). Just look at the rules in the default filters to learn how. The "Suspects" tab is a good way to find the URLs to block.
 
Comment

cyberghoser1

macrumors member
Original poster
Nov 18, 2009
98
0
Athens, Hellas
You're welcome!
Right off the box GlimmerBlocker tends to block less ads than adblock. This is not to hamper sites functionality by blocking too much. Fortunately creating personal filters and rules is simple (while not as easy as in adblock). Just look at the rules in the default filters to learn how. The "Suspects" tab is a good way to find the URLs to block.

Thanks again, now WebKits is my default browser :)
 
Comment

PowerPCMacMan

macrumors 6502a
Jul 17, 2012
800
0
PowerPC land
G5 Quad?

Hello,

Will this Glimmer Block work for me on my G5 Quad? This things a beast in itself. I can play flash with no problems on it, but certainly would like to speed up Webkit on my G5. Someone let me know if I will see any differences if I were to totally get rid of java script entirely from my G5.

Thanks,
 
Comment

Wildy

macrumors 6502
Jan 25, 2011
323
0
In what context, blocking ads or blocking JavaScript? JavaScript, unlike Flash, is essential to the functioning of some sites; so some sites may work, while others won't. If you are experiencing slowdown due to JavaScript, it's quite possible that a lot of it is from all the extra scripts which are loaded in the background which don't have anything to do with the functioning of the site - think: social media / sharing extensions, ads, tracking / analytics scripts etc. All of these can be blocked with GlimmerBlocker with very little effort and will not affect the core functionality of any sites you visit.

tl;dr Give it a go! There really isn't anything to lose. Just remember to add rules for blocking what I outlined above. If you want a hand then give me a shout.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.